Connect with us

problem of simulation of VCO in SPICE

Discussion in 'CAD' started by cici, Jun 10, 2004.

Scroll to continue with content
  1. cici

    cici Guest

    Hi,

    I am doing simulation in SPICE. It is a ring VCO. WHen I just did
    ..TRAN analysis, there is "parameter out of range or the wrong type" on
    screen. What is the problem? I am using TSMC25 models. It works well
    in my current mirror.

    Thank you!
     
  2. Jim Thompson

    Jim Thompson Guest

    "SPICE" what?

    ...Jim Thompson
     
  3. cici

    cici Guest

    It is SPICE3. Thanks.
     
  4. Jim Thompson

    Jim Thompson Guest

    I don't know Spice3, but I'd guess it can't handle higher level
    models. Isn't TSMC_0p25 in at least BSIM3.3.2 format? My
    five-year-old ones are and I think recent ones are in EKV format.

    ...Jim Thompson
     
  5. cici, Jim:
    TMSC models are hspice. hspice added a number of
    parameters to the Berkeley BSIM device, mostly dealing
    with how to compute dimensions. If you fully specify
    all dimensions(with areas and perimeters) you can
    probably ignore the warnings. If your spice3 treats
    them as errors, just comment them out of the model.
    You can verify with another simulator when you get
    a chance.
    I've never seen EKV models out of TSMC.

    --Mike
     
  6. Jim Thompson

    Jim Thompson Guest

    I have a TSMC EKV model set here dated 4/20/2004.

    ...Jim Thompson
     
  7. Jim,
    Wow, thanks, that's amazing. What level number do
    they use? I had been getting the impression that EKV's
    popularity was going south. I suspect that's not part of
    their mainstream model release, but a special library
    with limited distribution.

    --Mike
     
  8. Jim Thompson

    Jim Thompson Guest

    Level=55. PSpice threw a curve ball and designated it as Level=5,
    which was an old model level designator that was previously abandoned.
    I suspect you are right... it came from a client of mine with a
    special relationship with TSMC.

    ...Jim Thompson
     
  9. cici

    cici Guest

    Thanks for your information.

    My tsmc25 models is level 11. version3.1.
    When I use this model to simulate a simple current mirror in PSICE3,
    it doesn't have such
    problem. Only when I simulate VCO,this problem appears. I checked the
    topology, it is correct.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-