Connect with us

Please help me with this powered sub woofer!

Discussion in 'Troubleshooting and Repair' started by Torx, Jan 21, 2010.

Scroll to continue with content
  1. Torx

    Torx

    2
    0
    Jan 6, 2010
    JBL SUB300 POWERED SUB WOOFER


    The sub woofer will not come out of standby with the mode switch set to AUTO or ON. The funny thing is if I turn the power switch off and wait until the power LED gets real dim and flip the switch, it will power up. It will even go into standby after 15 minutes if I have no signal applied to the LEF input.


    When I do trick it to turn on it is very unstable. It will go into standby if I try to drive the speaker to quickly. If I slowly add more sub input over several minutes it will stay on for hours. It appears to work better as it warms up. I have tried to find bad solder joints but I feel this is not the problem.


    I think the problem is in the over-current/ over temp / DC offset protection & relay driver section.


    Could anyone look at this schematic and give me there opinion on where I should be looking. Thank you in advance.



    Take care


    Joe


    Schematics can be viewed or downloaded from here.

    http://public.fotki.com/T0RX/jbl-sub/
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-