Connect with us

please help if you can

Discussion in 'Electronic Repair' started by [email protected], Mar 26, 2007.

Scroll to continue with content
  1. Guest

    I have a Zenith system 3 TV model #SY2593P made in august 1982
    It has been a good tv until yesterday when the pictuers went all fuzzy
    on me you can still see and hear it its just all fuzzy and static
    looking I have a Cabel box hooked up to it and i was wondering if
    anyone had any ideas on whats wrong with it and any possible
    solutions


    Things ive tried is Hooking the cable box to a different tv (pic came
    in fine on the other Tv)
    ive tried other wires still fuzzy pic on Zenith

    Thanks for the help
     
  2. clifto

    clifto Guest

    As near as I can make out, it's a problem with the antenna connections
    or the tuner.
     
  3. Jeroni Paul

    Jeroni Paul Guest

    The focus voltage has gone low or dead. This is a quite high voltage
    around 5 kV, not a place for hobbyists or starters. It could be the
    flyback focus pot is bad or open, or if the set uses a tripler they
    used to fail that way. You might try slightly moving the focus pot and
    see if it goes out of the bad spot.
     
  4. Guest

    too vague, do you mean focus is bad? or picture has gone snowy? Or
    nowt but snow?


    NT
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-