Connect with us

PIR help

Discussion in 'General Electronics Discussion' started by xx_METAKNIGHT_xx, Aug 1, 2011.

  1. xx_METAKNIGHT_xx

    xx_METAKNIGHT_xx

    1
    0
    Aug 1, 2011
    Hello all

    I am a beginner in the world of electronics. For my current project, I am trying to get a PIR sensor to interface with a microcontroller. Unfortunately, I am having trouble getting a stable response.

    I have tried both the Panasonic NaPiOn PIR sensor and the Parallax PIR sensor. I wired it up to a simple test circuit (vdd to +5v, gnd to ground, and output -- 100 ohm resistor -- LED -- ground). In both cases, even after the setup time recommended by the datasheet has passed, the LED spazzes randomly when in idle mode. The circuit seems to trigger OK most of the time, but it is hard to tell when it is actually triggered or when it is giving false positives like crazy.

    I tried setting up a low-pass filter, but the idle state doesn't seem to have a regular pattern to filter out. I also tried using a comparator to isolate true highs from accidental highs, but it didn't work. Finally, thinking that my body heat has been triggering the PIR, I turned it on, walked out of the room for two minutes (4x the reccomended setup time), and watched it continue to randomly blink.

    Does anyone have any suggestions for working with this part without losing one's sanity?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-