Connect with us

Pioneer SX-303R

Discussion in 'Troubleshooting and Repair' started by oakdust, Feb 12, 2011.

Scroll to continue with content
  1. oakdust

    oakdust

    38
    0
    Feb 27, 2010
    This unit was given to me not working and when I removed the cover I found R662, R625 and Q622, burnt. Q622 just had the three legs and R662 was a pile of char. (see page 15 of the attached schematic) I know this is the overload dectection circuit. Naturally the power amp transistors are bad and probably several other componets. I was wondering if anyone else has run accros this before or have any idea what could have cause it. All the fuses are good and no discloration in the power supply circuit.

    I think the file was to big to attach so here is a link

    https://sendnow.acrobat.com/?i=aS8lnPHgO3SCloMoeLSKxw
     
  2. karlfoxman

    karlfoxman

    11
    0
    Feb 12, 2011
    Are you meaning R562??
     
  3. oakdust

    oakdust

    38
    0
    Feb 27, 2010
    Sorry I did have the number wrong, it is R622 that is a pile of black char on the board. The bottom of the board has it as R622. Sorry for the confusion
     
  4. karlfoxman

    karlfoxman

    11
    0
    Feb 12, 2011
    I would have a look at Q2, not supprised some of the resistors are burnt. Ended up having rectified mains on them by the look of it. Do you think one channel had wrong impedence on it? Check components on that buffer circuit too, Q601 / Q602. Am I right in saying that circuit is removing the load via a relay after sensing a overload?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-