Connect with us

Pic - Win98 Problem

Discussion in 'Electronic Basics' started by Grey, Oct 17, 2004.

Scroll to continue with content
  1. Grey

    Grey Guest

    This is really a Win98 question, so apologies if a bit OT.

    I am playing with a circuit idea around my PIC 16C74/JW on my protoyping
    board, debugging my software (or should that be firmware?) which will drive
    my circuit. As I'm using PicBasic to create my program, there is a handy
    facility called Serout which will send data to the serial port of my PC. Its
    great for watching values and
    seeing what's going on. I have a serial link between PC & Pic which has
    worked well in the past, but having got it out for the first time in a
    while, something's not right. I am using Microsoft Quickbasic to read in the
    Pic data, using the lines:

    OPEN "com1:9600,n,8,1,cd0,ds0,op0" FOR INPUT AS #1
    CLS
    Again:
    theChar$ = INPUT$(1, #1)
    PRINT theChar$;
    GOTO Again

    But when I run the prog, nothing happens. If I break the program with
    CTRL-Break and run it again (F5), it bursts into life and all is well.
    MSQ-Basic is being run under Win98SE. I have tried messing with the Com1
    settings in device manager, to no avail. Is there a basic reason why
    MSQ-Basic is behaving this way? I know it used to work without problems some
    time ago, so I may assume some program may be messing it up, but I have
    tried it on other PC's. If it helps, the Pic is sending out data inverted at
    TTL levels (as it has always done) and I have checked for good voltage
    levels.

    Any ideas?

    Graham
     
  2. Franks

    Franks Guest

    try like this:
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-