Connect with us

PIC programmer problem

Discussion in 'General Electronics' started by Emil Johnsen, Apr 21, 2004.

  1. Emil Johnsen

    Emil Johnsen Guest

    Hi,

    I'm trying to program a PIC16F826 with a JDM programmer ("Multi chip
    programmer" from http://www.talkingelectronics.com) and IC-Prog 1.05C.

    I always get the error message "Verify failed at address 0000h!".

    Anyone know what the problem can be?
     
  2. You don't happen to mean 16F628 do you?
    Potentially lots of things at this point. Did you erase the chip first?
    If so, did you try doing a blank check after the erase? Did you set the
    proper chip type in the programming software? How about the CONFIG
    bits? Does your computer's serial port output a high enough voltage to
    put the chip into programming mode? If it's a laptop, probably not.
     
  3. Emil Johnsen

    Emil Johnsen Guest

    You don't happen to mean 16F628 do you?
    I ment to write PIC16F628. This is what I have selected in IC-prog as well.

    The chip is new and blank. I have also erased it and done a blank check to
    be sure. (Tried a second new chip as well.)

    Oscillator: Tried every option while keeping the settings below.
    CP: off
    WDT, PWRT,BODEN,LVP,CPD: off
    MCLR: on

    I'm not sure about the voltage. I have measured the MCLR pin while
    programming and got 11.8-12.2 volts. I'm not confindent this is accurate
    because my voltmeter is slow to respond to changing voltages. I'm not using
    a laptop.
     
  4. I assume it passed the blank check then.
    You should probably turn ON the PWRTE, but it's not the problem.
    It's supposed to be 13V, so you might not be getting enough voltage to
    the PIC to put it into programming mode. Apparently this is a common
    problem with JDM type programmers. Can you try it using a different
    computer? Will the software let you examine the contents of the PIC
    after you do an erase/blankchk/program cycle? If so see if it looks
    like anything at all was written to the PIC.
     
  5. Emil Johnsen

    Emil Johnsen Guest

    It's supposed to be 13V, so you might not be getting enough voltage to
    I got a card IO card with 2 com ports. Using these ports it works fine, so
    it was my com ports that caused the problem.

    Because of some driver problems (the new ports doesn't work with
    totalio.sys) it still doesn't work in XP, but from Win98 I programmed the
    chip with no error messages.

    Thank you for your help.
     
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-