Connect with us

PiC A/D loading signal

Discussion in 'General Electronics Discussion' started by Rajinder, May 1, 2018.

Scroll to continue with content
  1. Rajinder

    Rajinder

    433
    7
    Jan 30, 2016
    Hi
    I have a voltage divider circuit consisting of a 20K at the top and 10K to ground. Centre pin to PIC A/D. The pic is used to measure high to low transitions of a square wave pulse. So the A/D is not used. I am sure my signal is being loaded.
    Can i add a voltage follower after the voltage divider, using a opamp? Or is there a transistor cobfiguration that i can use to do the same? I am just trying to eliminate the problem.
    Thanks
     
  2. Minder

    Minder

    2,966
    626
    Apr 24, 2015
    What is the source of your square wave pulse signal?
    Why the voltage divider?
    M.
     
  3. Rajinder

    Rajinder

    433
    7
    Jan 30, 2016
    The source is a feedback from a piezo at 3KHz. It is 7V pk to pk. Hence the voltage divider to bring it to a level that the PIC input can handle.
     
  4. Rajinder

    Rajinder

    433
    7
    Jan 30, 2016
    If i try and use a 200K and 100K, woyld that be a sensible thing to do. As i am not using the A/D of the PIC, di i need to worry about input impedance of the I/O line.
     
  5. Minder

    Minder

    2,966
    626
    Apr 24, 2015
    You may need to find a better way of conditioning the 7v pk to pk signal.
    M.
     
  6. BobK

    BobK

    7,682
    1,686
    Jan 5, 2010
    The PIC is not loading it, it is the voltage divider. Increasing the resistors to 100K and 200K will help and should not effect the PICs ability to read the digital signal.

    Bob
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-