Connect with us

Philips MX3900D surround system power on problem

Discussion in 'Electronic Repair' started by Cooper, Feb 1, 2006.

Scroll to continue with content
  1. Cooper

    Cooper Guest

    My surround system just started to have a problem. The standby/o
    switch flickers between a green "on" light and a re
    "standbylight" and won't power up. I downloaded th
    service manual, but I can't even get into the diagnostics program.
    I'm not sure what to do. I've searched the net quite a bit and foun
    that other people have had the same problem with this unit. I'm to
    cheap to send it to a repair shop. Can anyone recommend a website o
    resource to help diagnose the problem

    Thank
     
  2. nvic

    nvic Guest

    Has it been unplugged and left to sit? Sometimes, Microprocessors just
    lose their minds...Happened to My Cable Box twice.
     
  3. Cooper

    Cooper Guest

    We use it just about every day. After the incident, I have had i
    unplugged for three to four days and still doesn't fix the problem
     
  4. I'm too
    Just about says it all. Unless this is a common problem with discussions etc
    going on out there, you're probably unlikely to be able to repair it
    yourself.

    Maybe time for a new unit - hopefully not a Philips.

    For Surround receivers I recommend Yamaha, Sony, Denon, and Onkyo.


    Mark Z.
     
  5. insulator

    insulator Guest

    True words...but don't you think the fuse has burnt....Well as u guy
    all said...its doesn't power up....i had the same problem too....but
    went to the electronics store...You can't find the fus
    anywhere....Sucks huh...need a new dvd sound system....
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-