Connect with us

Panasonic home theater SA-HT930 , receiver won't turn on?

Discussion in 'Troubleshooting and Repair' started by Vaironl, Nov 6, 2011.

Scroll to continue with content
  1. Vaironl

    Vaironl

    3
    0
    Nov 6, 2011
    I have a panasonic home theater system Model: SA-HT930
    The problem is that the receiver is not turning on. The bass which transmit the electricity to the reciever, does turn on fine. This happened yesterday when we were moving to a new house. Please provide multiple answers if possible.
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,305
    2,738
    Jan 21, 2010
    I can't give you multiple answers. I can't even give you one.

    I don't understand what you mean by:

    You need to tell us if the device has a power switch an if it does anything at all (indicator lights, hum from the speakers, etc.)

    Does the receiver have a fuse? Have you checked it?

    Did anything happen while you were moving? Was the device turned on while you connected or disconnected speakers (could you have accidentally shorted something)?
     
  3. Vaironl

    Vaironl

    3
    0
    Nov 6, 2011
    Sorry for the lack of detail, my first language is not English.
    But I found out the input for the electricity is the problem. If I apply a little bit of pressure on the cable, it turns and if I let go , it turns off
     
  4. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,305
    2,738
    Jan 21, 2010
    replacing the power cable is the first thing to try. If this doesn't work, there may be a loose connection inside.

    Whether this is 1 or 2 things to try depends on whether the power cable plugs into the receiver or whether the cord is integral.
     
  5. Vaironl

    Vaironl

    3
    0
    Nov 6, 2011
    Well I did switch the end of the cable, therefore I believe is not the cable. Is the input of the receiver. What I believe is, when my friend disconnected the cable he did not press a button which releases a lock, therefore the input probably got slanted when he applied pressure to the cable?
     
  6. NMRF

    NMRF

    1
    0
    Jan 25, 2015
    ===============================
    I have a Panasonic True Theater Blu-Ray Home Theater sc bt730 also listed as said bt730 w/ Wireless read surround Speaker system. Unplugged for ~ 1 month & cleared pwr from the cooacitors memory. Press pwr & rear fan kicks for a millisecond & quits. Have noticed F 61 flash on LCD readout, also seen problem mentioned on other sites concerning different model Panasonics.
    Included is a link to the manual...http://service.us.panasonic.com/OPERMANPDF/SCBT730.PDF
    If I remove cover to check for a fuse, will this void any defect warranty??[/QUOTE]
     
    Last edited: Jan 25, 2015
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-