Connect with us

Op amp/Zener voltage clamper problem

Discussion in 'General Electronics Discussion' started by Satindas, Jan 7, 2012.

Scroll to continue with content
  1. Satindas

    Satindas

    2
    0
    Jan 7, 2012
    I'm at the breadboard stage of a 4 channel Arduino cv quantizer which is all going pretty well so far except for one small problem which I can't solve.
    The cv inputs need to be clamped to 5V and this is the circuit:

    [​IMG]

    it simulates fine but on the breadboard even with nothing connected I get 0.27V at the output which is like messing up the whole thing. I've checked everything a zillion times and now my head hertz.
    Please help :)

    _________________
     

    Attached Files:

  2. Resqueline

    Resqueline

    2,848
    2
    Jul 31, 2009
    As far a I can understand the max output voltage can be Vdd - 9.7V, and negative inputs are clipped. Otherwise the output follows the input.
    I other words; the 5V clamping effect requires a regulated +/- 15V op-amp supply.
    So, what's your power supply (a single 9V I guess?), and what op-amp are you using?
     
  3. Laplace

    Laplace

    1,252
    184
    Apr 4, 2010
    It appears there are two back-to-back diodes in series, so unless the opamp output exceeds 9 V there is nothing reaching the circuit output terminal except leakage from the '-' input terminal. Try disconnecting the diode from the opamp output and see if there is any variation in the 0.27 V.
     
  4. Satindas

    Satindas

    2
    0
    Jan 7, 2012
    Thanks guys I got this sorted.....a duff TL074 screwed my weekend but I learnt much along the way. ;-)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-