Connect with us

Okuma panel (CRT monitor)

Discussion in 'Troubleshooting and Repair' started by rebelroxy, Jul 18, 2011.

  1. rebelroxy

    rebelroxy

    14
    0
    Jun 6, 2011
    I don't know a whole lot about these monitors. I'm hoping ya'll could help me get started on this one. When I turn on the panel im not getting any picture. The tube does not glow in the back small portion like it should. I don't have schematics for it and was hoping for some tips on where to start. I am getting voltage to the card behind the tube. could the flyback have anything to do with it not coming on?
     

    Attached Files:

    • crt.JPG
      crt.JPG
      File size:
      85.9 KB
      Views:
      423
    • crt1.JPG
      crt1.JPG
      File size:
      70.4 KB
      Views:
      289
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,173
    2,689
    Jan 21, 2010
    Do you have a pinout for the tube? Have you checked the heater is getting power? Have you checked to see if the heater has continuity?

    Please be careful around picture tubes. They bite.
     
  3. davenn

    davenn Moderator

    13,225
    1,734
    Sep 5, 2009
    if the tube isnt glowing at the PCB end of the neck then there is no heater voltage.
    you need to identify the heater connections and measure their voltages seem to remember somewhere in the region of 6 to 12V, cant remember if DC or AC try both,
    usually AC voltage.

    Dave
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-