Connect with us

Odd RasPi Behavior?

Discussion in 'General Electronics Discussion' started by The Didact, May 27, 2015.

Scroll to continue with content
  1. The Didact

    The Didact

    17
    3
    May 17, 2015
    Hi,

    I've got a Raspberry Pi B+, had it for four-ish months now, love it. However, when I use a image of Raspbian (off the Raspi site) that's been written to a 8gb microSD card, half the time that I connect the power source, it fails to boot, and the power light stays a steady red. (Like it does when there's no SD card inserted.)

    But when I wrote a TinyCoreLinux card on the same 8gb card, it booted perfectly fine. (Albeit with no GUI)

    Has anyone else experienced this?
     
  2. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    Power supply details and peripheral details please.
    The Raspi is susceptible to brown outs caused by sudden power draws, or inadequate power supplies.

    I'd check that first. Remove peripherals, then try a different Power Supply.
     
  3. Anon_LG

    Anon_LG

    453
    117
    Jun 24, 2014
    This brings back dark memories of plugging in my raspberry pi, sitting there for over two hours trying to work out what exactly I was doing wrong, only to find repeatedly that I had not put in the SD card. :D

    There was one time however that the SD card was in, I found out that I had a 4 socket extension cable, all of the sockets were populated and my Pi could not get enough power.
     
    Gryd3 likes this.
  4. The Didact

    The Didact

    17
    3
    May 17, 2015
    Yup. It's running on 5V of juice at 500mA. (Off my Wii, actually...) and it has two peripherals: A lightless keyboard and small mouse, both wired. Doesn't seem like much.

    Also, in regards to SD card, this may sound crazy, but it has been known to eject the SD card by itself from time to time. o_O
     
  5. Gryd3

    Gryd3

    4,098
    875
    Jun 25, 2014
    Did you still use the same peripherals with tinycore?
    You are borderline on the minimum requirement for the B+ only providing 500mA.
     
  6. BGB

    BGB

    154
    11
    Nov 30, 2014
    I have a B, WiFi dongle, and a webcam, and this pulls 700mA.

    mouse+keyboard may pull enough power as to leave a 500mA supply not providing enough power to run the RPi's CPU or other onboard electronics.
     
  7. The Didact

    The Didact

    17
    3
    May 17, 2015
    Gotcha. Thanks a lot, I'll up the power supply.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-