Connect with us

NEW Mitsu VCR no Stereo

Discussion in 'Electronic Repair' started by John, Dec 18, 2005.

Scroll to continue with content
  1. John

    John Guest

    Hello,

    I bought a "new" Mitsubishi VCR on Ebay and NEVER really used it. Now
    when I try to record or play, the HIFI is dead ! (only linear sound). I
    have never seen this problem before (I have fixed many VCRs in my
    day...)

    Any ideas ? I mean it can't possibly be the video head or anything
    since it was new in the box and has about 2 hours of play time on it
    !!!

    Thanks !
    also email please...

    John J. Hopf
    Newport, RI
     
  2. Guest

    How about doing some basic user troubleshooting?
    Do prerecorded hifi tapes playback correctly in hifi mode? Answer this
    and it may narrow down the problem a lot.
    Is there a user menu setting to change the audo playback/record mode?
     
  3. Could be the one tape that was played left some dirt on the drum...
    Or maybe it is new defective...
    or maybe it was not really a new machine...
    or???....
     
  4. elephant

    elephant Guest


    Check the on-screen programming. My Mitsu has a section for audio.
    Here, you can select linear, Hi-Fi or a mix of both. There are no
    switches on my machine to select the audio, has to be done using the on
    screen menu.
     
  5. John

    John Guest

    No, fresh, prerecorded tapes also do not play in HiFi. I searched the
    menu settings (as I assumed that MUST be it), but couldn't find
    anything about stereo or HiFi there. I will check it out again.

    Thanks!
     
  6. John

    John Guest

    Oh, my email is actually
     
  7. ChrisCoaster

    ChrisCoaster Guest

    Dumb question, but need to ask:

    Does it say "HI-FI" on the tape door or cabinet of the VCR?

    If not, then it's just a "linear" stereo VCR, of which many were built
    in the mid-late 80s. It was a "step up" from monaural VCRs but will
    not play back HI-FI tapes in stereo.

    Sorta like an "Extended-Def" TV set today - not *quite* HD. :p

    -CC
     
  8. John

    John Guest

    Yes, it's definitely HiFi ! It worked great as HiFi at first. I
    bought it as a spare for my other aging HiFi units and have it hooked
    to my high end stereo system, so I definitely know the difference! - I
    think it is model HSU-422UR and is only a few years old.
     
  9. John

    John Guest

    Yes, it's definitely HiFi ! It worked great as HiFi at first.
    I bought it as a spare for my other aging HiFi units and have it hooked
    up to my high end stereo system, so I definitely know the difference! -
    It is model HS-U575 and is only a few years old.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-