Connect with us

Need help troubleshooting a Compaq Presario SR1365CL (ASUS K8S-LA)

Discussion in 'Electronic Repair' started by Peter Bogiatzidis, Apr 6, 2007.

Scroll to continue with content
  1. Hello,

    I'm trying to fix a Compaq Presario SR1365CL. The owner worked on it and
    somehow decided that the hard drive was at fault. I'm not sure what else was
    tried in order to "fix" it. Currently, PC will not boot Windows XP Home, but
    BIOS can be entered and changed and it does recognize the hard drive.

    After numerous attempts at trying to restore the original drive (Compaq has
    a restore partition on it) or install Windows on a new drive, I took it to a
    local computer repair shop to have it checked out. The consensus was that
    either the motherboard or BIOS was at fault. This is an ASUS K8S-LA
    motherboard OEM'd for Compaq. Unfortunately, the BIOS can only be updated
    through Windows.

    How can I prove that it is either the motherboard or the BIOS at fault? Is
    there any way to update the BIOS without using Windows? I've already checked
    Compaq's website without any success. Any pointers would be greatly
    appreciated.

    In the meantime, I also tried sourcing an original replacement motherboard,
    but only found an expired auction on EBay, which offered an untested one
    that was parted out of an old PC. Not a reliable way to go in my opinion.

    Does anyone have a reliable source for either an exact original replacement
    motherboard or know of a specific model that can be substituted for the
    original without having to replace the CPU? I'm doing this as a favor for
    someone who inherited it from the original owner and can't really afford a
    new PC. If this can be done for under $100, then it would be worthwhile and
    allow them to get in the game.

    Thanks in advance to those who post a reply here to the group.

    Peter.
     
  2. Could be a bad hard drive.
     
  3. Franc Zabkar

    Franc Zabkar Guest

    If the BIOS is allowing you to see the hard drive, then I expect it is
    OK. Anyway, if you really want to try a flash upgrade, then boot to a
    DOS floppy and run Uniflash.

    http://www.uniflash.org/

    It doesn't appear that your board's chipset (SiS 760 / SiS 964) is on
    the current Uniflash list, but you could at least try reading the BIOS
    chip without fear of damaging your board:

    http://www.uniflash.org/hardware.htm

    Otherwise I'd try a disc diagnostic tool such SeaTools for Seagate
    drives. You need to run this from a floppy diskette. Other HD
    manufacturers have their own tools.

    Hard Drive Diagnostic Programs by Vendor:

    OnTrack Data Advisor:
    http://www.ontrack.com/freesoftware/#dataadvisor

    IBM/Hitachi Drive Fitness Test:
    http://www.hgst.com/hdd/support/download.htm

    Western Digital Data Lifeguard Tools:
    http://support.wdc.com/download/

    Quantum/Maxtor PowerMax:
    http://www.maxtor.com/en/support/downloads/powermax.htm

    Seagate SeaTools:
    http://www.seagate.com/support/seatools/index.html

    Download:
    http://www.seagate.com/support/seatools/B7a.html
    http://www.seagate.com/support/seatools/seatoold_reg.html

    The above list is reproduced from this old post by Glen Ventura:
    http://groups.google.com/group/microsoft.public.win98.gen_discussion/msg/e4981c19fab8355b?hl=en&

    - Franc Zabkar
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-