Connect with us

MOSFET circuit problems

Discussion in 'General Electronics Discussion' started by AE35, Feb 14, 2013.

Scroll to continue with content
  1. AE35

    AE35

    1
    0
    Feb 14, 2013
    Hi all! My first post here :)

    I have a mosfet circuit, 'diagram' (show in the bottom)

    The problem is, when I hook it up the circuit to a coil and power supply, the coil
    fires right away, even then the circuit is not connected to the controller inputs. And
    then at this point, it shouldn't fire at all.

    I've tried rebuilding the circuit three times, and I've tried two power supplies(36V, 24V)

    I really need some advice on this, it's driving me crazy! The MOSFET is an IRLZ44
    logic-level. It should be able to handle 24(or 36V)

    Thanks!!


    [​IMG]
     
  2. john monks

    john monks

    693
    2
    Mar 9, 2012
    1. Verify that the metal tab is not connected to anything.
    2. Verify that the gate to source is 0 volts.
    3. Verify that the connections are correct. With tab up and facing the lettering the gate is the left lead. The drain is the center lead. The source is the right lead.
    4. Verify that the diode is working and facing the right direction.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...
Electronics Point Logo
Continue to site
Quote of the day

-