Connect with us

Mitsubishi TV problem

Discussion in 'Electronic Repair' started by Toby Marsden, Oct 24, 2004.

Scroll to continue with content
  1. Toby Marsden

    Toby Marsden Guest

    Hi folks,

    I've just bought a second hand Mitsubishi TV - worked fine in the
    vendor's house, but got it home and although it will go onto standby,
    any attempt to switch it "on" and get a picture displayed results in
    it turning itself off within 1/2 second or so, and remaining
    completely off for anything up to a minute, until the whole thing
    starts again.

    Does this point to anything in particular? I'm thinking it must have
    got bashed in the car on the way back, but I really don't remember
    this happening...

    TIA for any help,

    Toby
     
  2. Art

    Art Guest

    Gov: you may want to post the model number and chassis number if available.
    Basically my guess would be some type of power supply or protect problem.
    Generally one will need to open the tele up and do some basic diagnostics
    inclusive of verifying presence of necessary standby and operating
    potentials. Also making sure that nothing got disconnected or cracked as a
    result of transporting it.
     
  3. JURB6006

    JURB6006 Guest

    What he said.

    Also if it's cool or cold outside it might have weal lytics. Cool them down
    enough and they act up, but they're OK when warm. If it's shutting down
    immediately there are probably weak lytics in the power supply, and it's
    possible the seller wasn't even aware of it. IT's actually possible that there
    was no damage, and really no culpability anywhere here, except maybe the
    manufacturer.

    An ESR meter would be handy about now.

    JURB
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-