Connect with us

Mitsubishi PIP???

Discussion in 'Electronic Repair' started by Thomas Abell, Oct 13, 2003.

Scroll to continue with content
  1. Thomas Abell

    Thomas Abell Guest

    I have a question regarding a 35" direct view Mitsubishi TV, Model CK-35402.
    This set is in a customer's house quite a distance away and I am hopeful
    that I can repair it in one trip.

    Symptoms are Sound-OK, On-Screen Menus-OK, video missing in all modes, both
    tuner as well as all external inputs. The problem came on suddenly. My
    question is this..if it were a common PIP issue, would we not expect to see
    normal video when using the aux inputs? If it helps, this set uses the
    930B552012 PIP module but I don't know anything else about it yet.

    My gut tells me that the problem lies somewhere in the video switching
    circuit, not the pip. What do you all think? TIA!
     
  2. JohnAce

    JohnAce Guest

    Most likely it's the PIP. You should be able to see the leaky caps on the
    board. You can bypass the pip to make sure.
     
  3. Bill Jr

    Bill Jr Guest

    I would have to concur.
    All video sources go thru the PIP module.
    Both the main and PIP source.

    Good Luck,
    Bill Jr
     
  4. James Sweet

    James Sweet Guest

    This is almost always the PIP board, and even if that board isn't causing
    the current problem (unlikely) it will be in the near future, I suggest
    replacing the surface mount caps on it, I repaired several of these within a
    few months that all had the same problem.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-