Connect with us

Mig welder help

Discussion in 'Troubleshooting and Repair' started by Laurence Falconer, Oct 14, 2015.

Scroll to continue with content
  1. Laurence Falconer

    Laurence Falconer

    1
    0
    Oct 14, 2015
    Hey guys I'm new to this site and need some advice. I have a Sealey mig 185 weld set that's worked faultlessly for years until now. Machine was working fine then one day just packed up whilst plugged in but idle. Mains power lead was a bit part worn so replaced it with new plug fuse etc and still nothing. Found a small fuse which had blown internally in the machine so replaced it. Still not working. Machine appears to not power up at all as I have no power light and the fan doesn't kick in. I have basic electronics knowledge so have checked the contactor for continuity and resistance and seems fine. I just don't know what too check next please help.
     
  2. Martaine2005

    Martaine2005

    2,675
    722
    May 12, 2015
    Hi Laurence,
    Is it the supermig?
    There is a pcb on the inside back at the top. Try and check the rectifiers there. I suspect that is the problem.
    Can you confirm voltage to that board and nothing after?

    Martin
     
  3. Martaine2005

    Martaine2005

    2,675
    722
    May 12, 2015
    upload_2015-10-14_11-45-40.png
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-