Connect with us

Marantz 1070 repair

Discussion in 'Electronic Repair' started by [email protected], Jul 27, 2004.

Scroll to continue with content
  1. Guest

    I've recently acquired one of these amps and it has almost been
    working.. It will often go for a few minutes and then the protection
    relay will cut out, although sometimes it doesn't cut in to start
    with. I have traced it through to the protection circuit kicking in
    due to DC being present on the output of the left channel. Haven't
    been able to trace it further than that yet... When it does work, it
    sounds fine.
    Any clues on where to start?
     
  2. I'd lean towards coupling capacitors, or the differential pair of pre-amp
    type transistors at the amp input stage. A can of freeze - mist might help
    narrow it down.
    I'm trying to remember - there was a particular type of transistor or two
    they had problems with back in those days. I think it was 2SD458, or maybe
    2SC1312.

    Mark Z.
     
  3. Chuck

    Chuck Guest

    One other component to check is a glass diode on the power amp board.
    These would fail fairly often and the symptom was D. C. offset. Chuck
     
  4. Guest

    Got it sorted... it was mostly a whole lot of dry joints in the power
    amp stage, but there was a pair of transistors in a darlington
    configuration driving the relay that was a bit dodgy too... The main
    one was a 2sc1318
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-