Connect with us

M5450B7 - 34output LED driver

Discussion in 'Electronic Basics' started by Jan Nielsen, Jun 22, 2007.

Scroll to continue with content
  1. Jan Nielsen

    Jan Nielsen Guest

    Hi,

    DataSheet:
    http://www.ortodoxism.ro/datasheets/SGSThomsonMicroelectronics/mXqrr.pdf

    I have a few of these and is trying to get them to work, sofar with no
    success.

    I have made a voltage divider with a 300ohm resistor and sent that to
    brightness control.
    Added a 0.47uf cap to the divider, and the +/- legs of the chip.
    Added +/- where needed (pin 1-20)
    Connected the data and clock to a picaxe.
    Not sure about enable if it should be low or high, but have tried both.

    With enable low there is a small change when the picaxe turn off a
    input, but theres only <1V on the output, when theres 5.1V on the input,
    that wont drive anything.

    The test code for the picaxe is here, not sure if it works either ofcause.

    #picaxe 18x

    symbol dataout = 0
    symbol clock = 1

    do

    SerTxd("OFF",CR,LF )

    HIGH dataout
    HIGH clock
    PAUSE 4
    LOW clock

    for b0=1 to 36
    LOW dataout
    HIGH clock
    PAUSE 4
    LOW clock
    next

    pause 3000

    SerTxd("ON",CR,LF )

    HIGH dataout
    HIGH clock
    PAUSE 4
    LOW clock

    for b0=1 to 36
    HIGH dataout
    HIGH clock
    PAUSE 4
    LOW clock
    next

    pause 3000



    loop
    -done-


    Its an old chip I know, and I werent able to find any exsamples on its
    use, except the datasheet, which as far as I can tell dont even say if
    enable needs to be low or high.

    Anyone know why it dont work ?

    /Jan
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...
Electronics Point Logo
Continue to site
Quote of the day

-