Connect with us

LTspice, Could not open library file

Discussion in 'General Electronics Discussion' started by Vinasse, Oct 14, 2015.

Scroll to continue with content
  1. Vinasse

    Vinasse

    11
    0
    Oct 14, 2015
    Hello,

    I am trying to simulate a Flyback converter using a Viper16L from ST Microelectronics on LTSpice.
    ST were nice enough to send me the Viper16L model .asy and .mod.
    I added them LTspiceIV\lib\sym and LTspiceIV\lib\sub respectively. And I added a Spice directive on my schematic to LTspiceIV\lib\sub\viper16l.mod.

    But when I try to run it, there is an error:

    Could not open library file "C:\Users\carmelovicari\Documents\DATI..."

    To be clear I am not this Carmelo Vicari (must be someone from ST), I guess I just need to change the path, but I don't really know how to do it...

    It would be really nice if someone could help me on this.
     

    Attached Files:

  2. eetech00

    eetech00

    95
    8
    Nov 17, 2014
    There may be an absolute path embedded in the .asy file.
    In ltspice, open the .asy file and check the attributes.
    Remove any absolute path's.
     
    Vinasse likes this.
  3. Vinasse

    Vinasse

    11
    0
    Oct 14, 2015
    Brilliant !

    Thanks a lot for this quick and perfect answer !
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-