Connect with us

Lost Picture

Discussion in 'Electronic Repair' started by Harry, Nov 27, 2005.

Scroll to continue with content
  1. Harry

    Harry Guest

    I am loosing the picture on my JVC AV-27730. It makes a little crackle
    sound and would come back when I would slap the set on the side. This
    worked for a few weeks but no more. I took the back off and if you flex the
    main board with a little pressure the picture will come back for a while but
    not long. I am being careful to not touch anything where I can be shocked.
    (I think.) Thanks for any help.
     
  2. The crackle sounds like you are losing high voltage, and the fact that
    flexing the board makes the problem come and go indicates a loose
    connection.
    Most often it's caused by a bad solder joint. Use a magnifying glass to
    look for it. Start in the main power supply and the high voltahe sections.
    If you don't know how to do this, find a technician or TV repair shop.
    If it's only a loose connection, it will probably cost you just the
    standard labor charge with no parts.
    If you allow the symptom to continue, parts mey be damaged, making the
    problem most costly to repair - because the technician will need to find
    and replace the bad component(s) and find the original loose connection
    that caused it.
     
  3. Harry

    Harry Guest

    Thanks to you in helping me to diagnosis the problem with my JVC TV picture.
    I just got around to examining the board and found the culprit. I
    resoldered the joint and now I have a picture.

    Thanks again,

    Harry
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-