Connect with us

Logitech Z680 power issues

Discussion in 'Troubleshooting and Repair' started by RavenPhoenix, Aug 8, 2010.

Scroll to continue with content
  1. RavenPhoenix

    RavenPhoenix

    3
    0
    Aug 8, 2010
    Hi All,

    This is my coat check and 1st post rolled into one. I have been reading up on a few post on this forum for help with a problem I am faced with regards to my Logitech Z680 speaker/amp unit.

    The unit was working fine one day and just all of a sudden stopped powering on. I initially thought it was the fuse but have confirmed with a spare one and a multimeter continuance test that it's not the problem.

    There were no signs of failure prior to the unit actually not powering up at all. I have opened it up and confirmed that there is no burnt capacitors, resistors, IC's e.t.c and it appears that all the LM chip amps are still in fine working order.

    I have tried to do some troubleshooting with my limited knowledge and I have come down to what I think is the problem causing part.........The TOROIDAL TRANSFORMER. Although, I am not 100% sure as I'm not very certain on how to test it properly to see if there is a short in the windings.

    Before I go any further the specs of the toroid are as follows:

    The transformer is a Tenpao Model # TOU543005F0

    The diagram on the side shows the Primary as 240v brown 0v black and Secondarys with a 26.2v orange, 0v black, 26.2v yellow, and then a 14.5v blue and 0v blue.

    I have tried using the multimeter to test the secondary rails with red probe on orange and black probe on the 0v black but don't seem to get a very clear reading.

    What i would really like your much appreciated help with is either how to 100% confirm if it is the transformer that needs replacing or method to test the unit so I get a clear more definitive answer.

    If possible I would also like some advice on whether the Toroidal's I found at these sites below will be a suitable replacement for my unit. If so then which one would you recommend.

    https://secure.vividcluster.crox.ne....asp?ID=MT2114&CATID=19&form=CAT&SUBCATID=539

    OR

    http://www.tortech.com.au/product/900/

    Sorry to make it such a long post but if you still feel like it is not enough details then please let me know and I will try to answer them to the best of my ability.

    Thank you kindly in advance for you help and any sort of assistance/advice will be greatly appreciated.
     
  2. Resqueline

    Resqueline

    2,848
    2
    Jul 31, 2009
    That reading should be very close to 0 Ohms. But if you can do it, the best way is to measure it with power on to see if you get the input & output voltages indicated.
     
  3. RavenPhoenix

    RavenPhoenix

    3
    0
    Aug 8, 2010
    Thanks for your reply.

    I have tried testing the unit with the power in the following ways.

    probes red--->orange--->yellow but don't get any reading | multimeter set at 20 Volts ~
    probes red--->orange + black--->black but don't get any reading | multimeter set at 20 Volts ~
    probes red--->blue + black-->blue but don't get any reading | multimeter set at set at 20 Volts ~

    I have also tried with the power off but get similar results. I have only been able to test the secondary rails so far as the primaries are still solder in. I didn't want to unsolder or remove anything just yet in case it wasn't the power transformer. I have also tried setting the multimeter to resistance and I do get continuance. But I have a feeling I am doing something wrong or have set the meter at the incorrect mode.

    Am I setting the multimeter correctly and should be I setting it to 20 Volts AC or DC?

    One more bit of detail I would like to provide is I gone out to buy a non touch AC voltage tester (the one's that beep when a current is detected). The really weird thing is when I use it to test the unit it seems to detect a current from the mains cable all the way to the fuse but then it seems to stop close to the power switch??? Could this possibly mean that the power switch is faulty or dead? But it looks perfectly fine and I have checked the soldered connections that connect it to the fuse then to the mains as well and they all appear to be fine.

    Any help is greatly appreciated and thank you kindly in advanced.
     
  4. Resqueline

    Resqueline

    2,848
    2
    Jul 31, 2009
    No AC voltages out of the transformer means it's not getting mains power in, or if it does then an internal overtemperature fuse inside it has blown. Primary continuity?
    20V AC is the correct setting for measuring the low voltages. You'll need to set it to the 700V AC range to measure the mains input though.
    One may or may not want to trust the non-touch measurements, but switches do fail for various reasons. You can try to Ohm the switch (and the fuse) for continuity too.
    Or you can measure the AC voltages with the DMM at the mains input and then at each available point all the way to the transformer.
    I guess you're nervous about doing that but it's usually no problem. Just take care that the probe won't short the measuring point to anything else close by if it slips.
     
  5. RavenPhoenix

    RavenPhoenix

    3
    0
    Aug 8, 2010
    I have not been able to test the primaries at all yet as they are soldered directly on to the AC powercable--->switch---->fuse. Is it advisable to try to unsolder the connections and test it? I have been refraining from unsoldering anything just in case I bugger it up even more.

    I have been able to test continuity on the fuse though and that seems fine so at least I'm sure it's not the fuse. :D

    I actually just took the unit to a so called professional electronic repair man and he reckons that there are more than one problem with it. Apparently, there is a problem with the input and output of the unit??? (I'm not sure how he was able to test that without being able to get any power to it.) :confused:

    Also, he thinks that there may also be a problem with the power supply which is sort of confirming my concerns. He apparently tested the powerswitch as well and they was fine according to him. However, due to his lack of or should I say incoherent english skills I was not able to get a clear answer or diagnosis out of him. He said that it is unrepairable and even if it was he wouldn't be able to locate the required parts for it. I somehow find that hard to accept as in this day and age you can pretty much find any part with help of the internet. Also, I don't believe that this unit is damaged beyond repair as there are no burnt parts or signs of damage anywhere.

    May I ask if there is anybody you can recommend that is local for the Lidcombe/ Bankstown/Fairfield area of Sydney NSW that I can take it to for a 2nd opinion? Maybe you might be interested in having a stab at this one Resqueline? You seem to be a person of great wisdom and knowledge regarding electronics (Anybody hear how desperate I am in getting this fixed in my bum kissing :p )

    If there are any Pro's or experienced McGuyvers reading this post and are local then please contact me on 0406118897. I am a Professional IT Technical Analyst with 10years+ experience so can offer help and assistance with any IT (Hardware or software) assistance in return for your help. Or maybe even offer a gift of a laptop or mobile phone to anybody who is able to fix this for me. ;)

    UPDATE:

    I have just retested the unit as you have advised Resqueline. I managed to pull back the sheathing where the primaries connect to the power cable--->fuse--->switch and test with the DMM set to 700V~ with the power running but I don't get any sort of reading at all??? The DMM reading was 0 when the power was off and after I switch the power on the reading is still 0. I also tested the switch for continuity and when in the ON position there is continuity and none in the OFF position. I guess my theory about the switch being faulty just went out the door. I then tested the primaries for continuity and there appears to be none either with the power switch on or off.

    I also spoke to the repair guy again (or tried too converse anyway) and he told me that the part which is faulty is a SMD on the board which controls the Rear Left and Front Left channels. He reckons that the fault was caused by a shorting of speaker wires or turning the volume up too loud. I find that unbelievable because I just pulled the whole amp apart by unscrewing the board from the heatsinks and could not find any SMD's on the board. at all. Also, correct me if I'm wrong but isn't the output controlled by the 7x TDA chip amps that are connected to the heatsinks? I double checked these TDA chips and they all look like they are in good working order (no obvious marks/burnt/blown on the chips). I was thinking as a next step to try connecting a little EI transformer that I have pulled from another faulty el cheapo brand 5.1 speaker/sub/amp unit which I know is working 100% to see if the unit will power on. Before I do that though I would like to know if that is safe to do, meaning would I be stuffing more components up by doing so? I know that this little EI will probably not have sufficient power to run the Z680's properly but I was just hoping to confirm if the transformer was the only obstacle/problem I am faced with. I think the other faulty sub I pulled the EI from was only 50RMS so it probably just has 2x 12volt primaries.

    Any further assistance with this would be greatly appreciated and I would like to take the chance here to thank Resqueline for all his help and valuable advice thus far.
     
    Last edited: Aug 13, 2010
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-