Connect with us

LM386 Low Power Audio Amplifier IC question

Discussion in 'Electronic Design' started by Brad Davy, Nov 13, 2003.

Scroll to continue with content
  1. Brad Davy

    Brad Davy Guest

    I recently built a low power audio amplifier based on the LM386 IC to boost
    the output of my Palm Zire 71 MP3 player. I followed the standard circuit
    in the datasheet for a gain of 20, but when I tried it out, there was a
    tremendous amount of noise in the circuit. Adding a .1 microfarad
    capacitor between each of the audio inputs and ground eliminated this
    noise, and the amplifier works beautifully. Can someone tell me why adding
    the small capacitors between the input and ground eliminated the noise?

    Thanks
     
  2. Did the noise sound like a 60 cycle hum?
     
  3. mikem

    mikem Guest

    I ran into something like this when building a stereo amp to boost the
    output of a Sony CD player so that it could drive my aircraft
    headphones (hiZ). I discovered that the "common" side of the headphone
    jack on the Sony was tied internally to the tap between the two 1.5V
    batteries, instead of being referenced to the ground side of the
    external power DC power jack.

    If I tried to run the Sony on external DC power, there was a
    tremendous amount of "hash" present as a common-mode signal between
    the audio jack and the external ground. (Seemed to have to do with the
    chopper that controls the motor that spins the CD).

    The solution was to build an audio amp which has a true "differential"
    input (common-mode-rejection ratio of ~90db).

    MikeM
     
  4. Brad Davy

    Brad Davy Guest

    No, it was definitely not 60 cycle hum. It was more like a high pitched
    squeal. My theory is squeal. My theory is it was coming from the common
    ground from the Zire 71 (processor operates 71 (processor operates at
    144mHz). I don't have an oscilloscope to track it down, so I was just it
    down, so I was just playing. Had the capacitors, so I tried it, and it
    worked. Note that the worked. Note that the amplifier is powered by a 9v
    battery, and everything is tied to a common gr is tied to a common ground,
    including the audio output from the palm.
     
  5. The LM386 is notorious for being unstable and very sensitive to supply
    bypassing. Make sure the supply pin is bypassed to ground with a
    high-quality aluminum electrolytic (or a lower-quality one paralleled with a
    0.1uF ceramic), close to the chip.

    By the way, your post contains some very odd repetitions. Read it closely -
    perhaps I should say "Read it cl read it closely."
     
  6. Dave VanHorn

    Dave VanHorn Guest

    The original app notes have a series RC on the output pin, to ground, which
    is a very good idea.
     
  7. Michael

    Michael Guest

    Maybe due to grounding, try grounding the speaker directly to the battery.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-