Connect with us

LM386 Audio Amplifier

Discussion in 'Electronic Basics' started by zero, Feb 16, 2005.

Scroll to continue with content
  1. zero

    zero Guest

    I am trying to build an LM386 audio amplifier on a breadboard but am getting
    "motorboating" oscillations.

    The layout on the breadboard is:

    At left is a Radio Shack condenser mic, biased with a 1K resistor, the
    output coupled via a 10uF capacitor to an inverting amplifier based on an
    LM741 op-amp.

    The inverting amplifier of the LM741 has a 1K input and a 220K feedback
    resistor for a gain of -220. 1/2 the supply voltage goes to the + input. The
    output is coupled via a 10uF cap to the LM386.

    The LM386 on the right of the breadboard is set up for a gain of 20. Its
    output goes to the snubber and is coupled via a 220uF cap to the 8 ohm
    speaker.

    Questions:

    A. Does this layout make sense? Is the 220 gain in the first stage and the
    20 gain in the output correct for audio signals and this circuit?

    B. To avoid ground loops, should I try to tie ALL grounds to the same point,
    including the mic's, the LM741's, the LM386's, and the speaker's? Or should
    I separate some components from others?

    Right now the mic, the LM741 and the LM386 have their grounds go to the
    breadboard's ground line. I've tried to keep them as close as possible.
    Also, I wired the speaker's and the snubber's grounds to the LM386's 4 pin,
    not the ground line.

    C. Bypass caps: where on the breadboard should I put them? Close to the 6
    pin of the LM386, the speaker, or the battery connections? I put a 220uF cap
    directly between the 4 and 6 pins of the LM386 but it didn't help. I
    paralleled it with a 0.1uF ceramic cap but it also didn't help.

    Any help will be appreciated.
     
  2. This provides a path between the positive supply and the high gain
    input, with only a 1k and 10 uf low pass filter. That pair has a
    corner frequency of about 16 hertz, not counting the parallel load of
    the microphone. This is probably the main feed back path affecting
    your oscillation. Try using a separate 9 volt battery for the bias
    source and see if the effect changes.
    This provides an input impedance of about 1k ohm, which seems very
    low, for a microphone biased through a 1k resistor. I think I would
    change this to a non inverting amplifier with the + input biased
    through a 100k resistor, so that the full microphone output voltage
    appears at the amplifier input.
    There is no right answer. Does this arrangement provide the needed
    gain?
    You want ot keep the big speaker and LM386 currents out of the ground
    line to the input section. That means that the power negative and the
    speaker return and the supply bypass for the 386 should go to the
    amplifier pin, as directly as possible. Then tie that node to the
    input group with a wire.
    That is still the right place for those components, so their currents
    do not produce I*R drops in any other paths.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-