Connect with us

LG 50 inch plasma

Discussion in 'Troubleshooting and Repair' started by wadec22, Aug 6, 2010.

Scroll to continue with content
  1. wadec22

    wadec22

    2
    0
    Aug 6, 2010
    TV went out during a storm and wouldn't turn on the next day. I opened up the back and there were 5 capacitors clearly blown on the power supply board. I have very general knowledge and minimal skill with such things, so I ordered a new power board off ebay. Cost 65.00, installed now the unit powers on with sound, but no picture.

    Someone hinted it may be the z-sustain, so I ordered one off ebay for 40.00, installed today, no difference. Any idea what to try next? Hate to just junk the thing...

    Thanks for any advice.
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,480
    2,827
    Jan 21, 2010
    Is there another power supply for the display? I'm not sure how these things work, but it is reasonable that the may be a separate power supply for the display and the rest of the TV.

    If not, look at where the power from the existing power supply connects to the display and see if you can locate any damage there (if you're really lucky it may be)

    Does your TV have other inputs? try them.
     
  3. wadec22

    wadec22

    2
    0
    Aug 6, 2010
    there is no other power supply and switching inputs doesn't do anything. it's like everything is working but the backlight.
     
  4. cisom99

    cisom99

    1
    0
    Aug 11, 2010
    Wade your in luck... Repair or replace your Y Sustain board... First check the fuses including the surface mount fuses. Also check the caps and moset (sometime the problem).. But replace the Y- Board and you should be ok..
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-