Connect with us

laptop motherboard problem !

Discussion in 'Troubleshooting and Repair' started by sony85, Oct 31, 2012.

Thread Status:
Not open for further replies.
Scroll to continue with content
  1. sony85

    sony85

    2
    0
    Oct 30, 2012
    As soon as I plug in the power adapter into the power jack the laptop turn on automatically . I don't have to press the power button !

    Any suggestion where this problem comes from ?
    Thanks
     
  2. GreenGiant

    GreenGiant

    830
    6
    Feb 9, 2012
    Sounds like the power button is jammed or broken, does the power button do anything when there is only the battery is plugged in?
    Does it do anything once the laptop is on?

    My guess is that the button is either stuck on and when you plug in the power cable it sends the signal to power up.
    OR
    Something with the switch from battery to plug is sending a signal for some reason through the power button
     
  3. shrtrnd

    shrtrnd

    3,681
    457
    Jan 15, 2010
    I'd go with GreenGiant's checks first.
    Other possibility is a broken power jack on the laptop, that is shorting connections
    to input power/switching.
     
  4. alipik

    alipik

    5
    0
    Nov 1, 2012
    i have the same problem as you, and this seems to be a rare one as no much data about it over net.
    i have the motherboard out and the launch board out so i excluded the jammed power button thing
    the weird thing is when plug the ac adapter jack it power on the motherboard without any interference then keep it running for 5 seconds then shut down by itself

    can a broken power plug cause this?
    or what to test then?
     
  5. CocaCola

    CocaCola

    3,635
    5
    Apr 7, 2012
    Verify that the one side of the switch is 'high' and the other 'low'...

    Pressing the button pulls the 'wake' line low (aka grounds it) and this is what turns on the computer... If a short (failed part) is pulling the line low or the pull up is not doing it's job of pulling that line high it will act as if the button is always pressed...
     
  6. alipik

    alipik

    5
    0
    Nov 1, 2012
    the launch board with the power button was tested on another motherboard and it work well
     
  7. CocaCola

    CocaCola

    3,635
    5
    Apr 7, 2012
    That doesn't address what I suggested you look at... The 'wake on press' function will be part of the motherboard/power supply logic not part of a button sub board...
     
  8. alipik

    alipik

    5
    0
    Nov 1, 2012
    ok i get you , i will try to check , thanx in advance
     
    Last edited: Nov 2, 2012
  9. aom4u2c

    aom4u2c

    3
    0
    Nov 2, 2012
    ok. There is a short circuit of the power switch terminal. Locate it on the board and seperate it.
     
  10. alipik

    alipik

    5
    0
    Nov 1, 2012
    ok after checking removed the power jack and reapply it the issue changed , now the power is on for 5 seconds then off and if press on again the same happens , meanwhile the processor fan is not getting power as it doesnot turn on while the fan itself is checked and working fine
    where to go now?
     
  11. aom4u2c

    aom4u2c

    3
    0
    Nov 2, 2012
    Power on problem

    At this juncture, make sure your RAM is good and it's connected on the motherboard before power on as well as the hard disk.
     
  12. alipik

    alipik

    5
    0
    Nov 1, 2012
    the hard disk is ok and the ram is ok both tested and both installed with no change
     
  13. mac007

    mac007

    1
    0
    Sep 22, 2019
    try to check cmos battery then try tu plugin without it.
     
  14. Alec_t

    Alec_t

    2,721
    723
    Jul 7, 2015
    Welcome to EP Mac, but did you check the date of this thread?
     
  15. thedoc298

    thedoc298

    8
    0
    Oct 4, 2019
    Does it work correct on the battery and not pluged in..?, if so swap the power supply they go crap and cause all kinds of intermitante problems.
     
  16. Alec_t

    Alec_t

    2,721
    723
    Jul 7, 2015
    Doc, did you notice this thread is ~7 years old?
     
  17. thedoc298

    thedoc298

    8
    0
    Oct 4, 2019
    No, lol but will watch a little better, but its cause im 7*9
     
  18. davenn

    davenn Moderator

    13,381
    1,784
    Sep 5, 2009

    you are A very young looking 79 ;) ;) :)


    welcome to EP
    yeah, just note the dates of the last posts before responding

    I will close this thread now to stop others from responding thinking that it's a new thread :)

    cheers
    Dave
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Thread Status:
Not open for further replies.
Electronics Point Logo
Continue to site
Quote of the day

-