Connect with us

Korg Sp200 very low output volume

Discussion in 'Troubleshooting and Repair' started by bloodyjo, Oct 7, 2020.

Scroll to continue with content
  1. bloodyjo

    bloodyjo

    5
    0
    Oct 7, 2020
    Some time ago i got a SP200 'as is' on a sale and want to make it back to work.
    Had some issues with keys and velocity but it is sorted now.
    The output volume is very low on headphones out and ultra thin on L/R outs
    I've already seen this post https://www.electronicspoint.com/forums/threads/korg-sp-200-piano-low-volume.293013/ but i think my problem is different.
    Service manual is still https://data2.manualslib.com/pdf5/104/10340/1033931-korg/sp200.pdf?d5bab82b522550709438da31578d5f70
    If i feed an audio source on pins CN5-1 and CN-3 subsituting the CPU board the volume is loud and useable and the volume slider works normaly. I think the problem come from the CPU board, how can i troubleshoot this one ?

    Thanks
     
  2. 73's de Edd

    73's de Edd

    3,157
    1,328
    Aug 21, 2015

    Sir bloodyjo . . . . .


    Considering that . . . . .
    If I feed an audio source on pins CN5-1 and CN5-3 [ thereby subsituting for the CPU boards audio output ] the volume is loud and useable and the volume slider works normally.


    If you will now consult my prepared mark up below, you will then see that there is still being one more stage of test ACCESSIBLE analog audio amplification.
    That is being the dual section NJM4580M IC11 beween those CN5 R&L audio channel test points and the output of the IC10 Digital to analog audio converter IC.
    Inputs at 5&3 and outputs at 7 and 1. . . . . . or it even might have its 9VDC supply missing at its pin 8 . . . .OR . . .its ground floating at pin 4.

    Test audio into pins 1 & 7 should be the same as your other test . . . . .but at 5 & 3 it should be overloading, if not being decreased in linput level.

    THEN . . . if . . . . NO output . . . check D/A Converter IC10 for its +5VDC supply presence and a GOOD L19 choke coil ( not open ckt) and no floating pins at 7-14-19-10 ground pins.

    Now, go ye forth and . . . CHECK . . . . it . . . . . O U U U U U U U U U U T !

    [​IMG]

    ONLY now being temporarily hosted at . . . .
    https://i.postimg.cc/vM5J4XWN/KORG-SP-200-Audio-Flow-Path.png




    73's de Edd . . . . .

    Say feller . . . . want to liven things up a bit ?

    Next time when being at the supermarket and waiting to use its indoors ATM, and thereby having a nearby captive audience, when the money finally spews out, then you fan out your money, wildly, wave and flail it around overhead . . . . then run around, all in a skitter and LOUDLY scream out . . . . .
    "I won! I won! I won! . . . its the 3rd time this month ! ! ! "


    .
     
    Last edited: Oct 9, 2020
    Martaine2005 likes this.
  3. bloodyjo

    bloodyjo

    5
    0
    Oct 7, 2020
    Thanks a lot ,
    So i've check 9V between pin 8 and 4 of NJM4580M IC11 , it's ok
    If i apply music between pin 1 and 4 or 7 and 4 i got low volume as well ...
    If i apply music 3 and 4 or 5 and 4 i get lower and distorted sound.
    I tried applying music between pin 1 of NJM4580M and common ground of the output board and i got loud volume the same as CN5 R&L audio channel.
    If i measure voltage between pin 8 of NJM4580M and this common ground i get 8.5V instead of 9...
     
  4. 73's de Edd

    73's de Edd

    3,157
    1,328
    Aug 21, 2015
    Methinks that the 'ole NJM4580M smells bad.
    If you have problems finding another, an easier to find NE5532 will sound a bit better.
     
    Last edited: Oct 13, 2020
  5. bloodyjo

    bloodyjo

    5
    0
    Oct 7, 2020
    I managed to replace NJM4580M by a TDA1308 i harvested from a dead sound card. Sound is louder but still not the same level has injected sound on CN5 R&L.
     
  6. bloodyjo

    bloodyjo

    5
    0
    Oct 7, 2020
    Found IT !
    I replaced TDA1308 with a lm4558, i noticed something weird volume was loud a after few minutes again low .... Seems that when the board is 'HOT' the volume is louder.
    I put a demo song and started to play with my heat gun and found the culprits ! Condensers C8 and C18 .... I replaced them with harvested ones and good !
     
    Last edited: Oct 14, 2020
  7. bloodyjo

    bloodyjo

    5
    0
    Oct 7, 2020
    Thanks for your help !
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-