Connect with us

Korg MonoPoly not powering up.

Discussion in 'Troubleshooting and Repair' started by Electronicaz, Jun 26, 2016.

Scroll to continue with content
  1. Electronicaz

    Electronicaz

    1
    0
    Jun 26, 2016
    Hi. I have a korg monopoly vintage synth which was working fine one day, then next day not firing up. I have checked visually all the internal 1A fuses but beyond that I'm not sure where to go next. My electronics experience goes as far as following instructions to modify, solder and desolder but not testing. I'm happy to follow any advice you may be able to give though. Thanks. Paul
     
  2. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,390
    2,774
    Jan 21, 2010
    the next thing I would do is to check the power supply rails. This will point you in one of 2 directions.

    At extremis, it could be your power cable is unplugged or that the speaker wire has become disconnected. It's unlikely to be that easy though. ;)
     
  3. 73's de Edd

    73's de Edd

    2,872
    1,216
    Aug 21, 2015
    .


    Sir Electronicaz . . . . . . .

    Find ye olde power cable and track down and then check out within my yellow circles over near the BIG " powerful" transformer for the unit.
    Then track down and see if the +15 volts DC and -15 volts DC and 5 volts DC are coming out at those test points being shown.


    Power Supply Circuitry for
    . . . . . . . "The Mean Machine"



    [​IMG]


    73's de Edd


    .
     
    Last edited: Jun 26, 2016
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-