Connect with us

Klipsch Powered Sub Won't Come On

Discussion in 'Troubleshooting and Repair' started by KilgoreCemetery, Apr 17, 2019.

  1. KilgoreCemetery

    KilgoreCemetery

    226
    9
    Apr 12, 2017
    I'm trying to fix a Klipsch SW-450 Powered Subwoofer. This has been a learning experience for me as I didn't really know a whole lot about switching power supplies when I started. Hopefully, that's changing as I go. I have not been able to find a schematic, so this is gonna be a bit wordy to make up for it.

    To start with, it just quit making sound and I realized that it was off. Initial inspection showed that the main fuse, a T4AL, 250V, was blown. I opened the sub up to check for further issues. Inside, there are only two circuit boards, one for power and the other appears to be the amp section. Side note: The On/Auto/Off switch is soldered to the amp board. Despite that, I checked the power board first.

    IMG_20190417_020330sm.jpg

    Hidden under the heatsink, I found that one of the big switching (I think) TO-220 transistors in the high voltage section had failed. It was one of two Fairchild J13009-2's. I wanted to order two, but when I placed the order, Digikey only had one available. I ordered the On Semiconductor FJP13009H2TU. Nothing else in the area appeared to be damaged or burnt and some quick checks with my multimeter didn't turn up any problems.

    IMG_20190417_020714sm.jpg

    After the parts arrived and were soldered in, I used my current limiter with a 100W bulb to power up just the power board. The bulb had zero illumination, but I could hear a faint clicking from the board itself. A little googling led me to believe that it was the protection circuitry triggering. After a lot of searching for bad diodes and the like, I did a little more research and refocused on replacing capacitors. I don't have an ESR meter (it's on the list), so I had to take the shotgun approach. I found that one of the two biggest caps on the board was leaking. They are 200V 220uF. Unfortunately, I didn't have anything that matches those specs, but I did have a pair of 200V 120uF caps. From there, I went about recapping the rest of the board too. There were also a pair of 63V 470uF caps that I didn't have good replacement options for, but I did pull them and they tested/looked fine, so they went back in.

    IMG_20190417_020731sm.jpg

    This solved the clicking problem and the high voltage side seems to be healthier. I now get plus and minus 166VDC going to the transistors mounted to the heatsink. However, even with both boards hooked back up and a dummy load in place of the speaker, I still don't get any sound out of it. I backed up a bit, tested the power board separately again, and found that there is no power going to the amp board. One jumper has three pins labeled +9V, GND, -9V. The other one has two pins and says +48V next to one of the pins where it connects on the amp board. I'm not 100% sure how the On/Auto/Off works with this setup, but I imagine it needs some sort of voltage going to the switch to work properly. Back to the drawing board.

    At this point, I tried two different things. One: I tried checking for switching in the high voltage section, and Two: checked every diode and transistor I could find on the entire board.

    I have a Sony Tektronix 335 oscilloscope, but I've never tried checking for switching before and at this stage there was a lot of second guessing on my part since I don't really know what to expect. Needless to say, I'm still not sure whether I found any or if I'm just reaching the limits of my vintage scope. One thing I did notice, though, is that there is no optocoupler or IC's on the high voltage side. The only connections to the low voltage side go through one of two transformers or one of two decoupling capacitors. This left me really wondering how the switching transistors are supposed to switch on and off without something controlling them. Are they actually switching transistors?

    From there, I moved on to hunting for more bad components. I did finally uncover a zener diode in the low voltage section that showed as a resistor. It was a 1N4148 and I happened to have a good one on hand. Power tested, but no change.

    IMG_20190417_020724sm.jpg

    There's a YG906C2 rectifier mounted to a heatsink which I think is probably supposed to supply the +48V rail, and four smaller diodes that look like they are supposed to create the plus and minus 9V rails. All of these tested fine.

    The only IC on the entire board is a Texas Instruments TL494CN. I'm not getting voltage on any of the pins. According to the datasheet VCC is supposed to be on pin 12. The only thing I could think to test on this was resistance between VCC and ground (pin 7), which shows 1.2k ohms. I tried tracing where the supply voltage is supposed to come from, but with the glue all over the board and no schematic, it's been tricky.

    IMG_20190417_020742sm.jpg

    I don't quite know where to go from here. I feel like I've missed some important clues and I'm hoping someone out there can point them out or at least point me in the right direction. Here's the power board top and bottom. Bread tie to assist with orientation.

    IMG_20190417_020628sm.jpg IMG_20190417_020651sm.jpg
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-