Connect with us

Kitchenaid stove problem

Discussion in 'Electronic Repair' started by Mike Amick, Apr 15, 2004.

Scroll to continue with content
  1. Mike Amick

    Mike Amick Guest

    I have a kitchenaid stove/oven kgrt507bal2 (with electronic ctrls) I dont
    have the manual. It is giving me a PF msg in the big window and F5:E3 in
    the time window.

    does anyone know where I can find info on this ?

    thanks a lot

    Mike
     
  2. Jerry G.

    Jerry G. Guest

    You must contact Kitchenaid for this type of thing. This is an error report
    from its microcomputer.

    --

    Greetings,

    Jerry Greenberg GLG Technologies GLG
    =========================================
    WebPage http://www.zoom-one.com
    Electronics http://www.zoom-one.com/electron.htm
    =========================================



    I have a kitchenaid stove/oven kgrt507bal2 (with electronic ctrls) I dont
    have the manual. It is giving me a PF msg in the big window and F5:E3 in
    the time window.

    does anyone know where I can find info on this ?

    thanks a lot

    Mike
     
  3. exray

    exray Guest

    Here's a few of the codes
    http://www.appliancestuff.com/codes.html

    In addition, PF usually indicates "Power Failure"

    -Bill
     
  4. Bill Janssen

    Bill Janssen Guest

    My problem with the door latch switch was from something being spilled
    on the surface and it dripped down inside to a protective baffel where
    it then
    dripped on to the door latch switch. The switch is a "microswitch" and
    could have
    been cleaned (probably) but it was replaced with a new one.

    Bill K7NOM
     
  5. Did he try resetting it?

    --- sam | Sci.Electronics.Repair FAQ Home Page: http://www.repairfaq.org/
    Repair | Main Table of Contents: http://www.repairfaq.org/REPAIR/
    +Lasers | Sam's Laser FAQ: http://www.repairfaq.org/sam/lasersam.htm
    | Mirror Site Info: http://www.repairfaq.org/REPAIR/F_mirror.html

    Important: The email address in this message header may no longer work. To
    contact me, please use the feedback form on the S.E.R FAQ Web sites.
     
  6. Mike Amick

    Mike Amick Guest

    (Sam Goldwasser) wrote in
    Thanks for all the replys you guys .. I had done some rewiring .. and I
    tried a different socket and the thing reset and worked .. then I went back
    to the original socket and it still worked .. so .. I think the thing that
    did it having it unplugged for 30 secs to reset it.

    thanks again
    Mike
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-