Connect with us

Induction hob problem

Discussion in 'Troubleshooting and Repair' started by amx, Mar 6, 2015.

Scroll to continue with content
  1. amx

    amx

    1
    0
    Mar 6, 2015
    Hi everyone.
    I bought an induction hob about 6 years ago, and it always worked great... Until now! It developed an intermittent fault. When I turn it on, it works normally, but then starts showing up three horizontal lines, and stops heating for a while. Then those lines go away, and it works normally again, but this is repeated over and over while cooking. I took it to repair, and they told me it needed new PCB's, which would cost me over €500. I'm almost sure it doesn't need new PCB's, because it has 2 PCB's, each one for 2 burners, and as this problem is happening in all 4 burners, I don't think they would both develop the same problem at the same time... This looks like a controller problem or something... Has anyone experienced something like this? And can anyone tell me how to fix it?
    Thanks!
     
  2. davenn

    davenn Moderator

    13,802
    1,941
    Sep 5, 2009
    hi there amx

    you have better start from the start and tell us what this unit is, I have no idea what you are referring to ??

    do you have www link(s) to any info on this thing please ?

    cheers
    Dave
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-