Connect with us

[IIYAMA] vision master pro 450 A901HT

Discussion in 'Electronic Repair' started by Pierre Merriaux, Jul 10, 2003.

Scroll to continue with content
  1. Hi,

    I have a dead CRT from Iiyama but all parts are manufactured by
    mitsubishi.
    Symptoms : After power on, the screen light its led for 1/2 - 1 second
    then turn off this led.
    After a little investigation, I noticed that when I unplug a cable from
    the main board (near a microcontroller) to the little board connected to the
    CRT, the led stay on.

    Anyone have seen this before ?

    Perhaps some of you have an appropriate schematic (or service manual) for
    this screen or for the same type of screen from mitsubishi.

    I took some pictures : http://lerhu.free.fr/iiyama

    Thanks,
     
  2. Dave D

    Dave D Guest

    There's not much to go on, it could be a failed HOT, a PSU fault or heaven
    knows what else. One thing for certain, powering on your monitor with
    unplugged connectors is asking for a whole load of trouble.

    Dave
     
  3. Hellraiser

    Hellraiser Guest

  4. Hellraiser

    Hellraiser Guest

    Incidentally, on a slightly different note, if any of you have a Vision
    Master Pro 510 (A201HT) that powers on but gives no picture, replace the
    2SC5570 (Q503 I think it is) and the fusible resistor R561. Worked fine for
    me, I'm now enjoying 20" of flat screened loveliness :)

    Hellraiser............>
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-