Connect with us

Ideas? Kenwood TM261A reset problem

Discussion in 'Electronic Repair' started by Gord S, Oct 4, 2007.

Scroll to continue with content
  1. Gord S

    Gord S Guest

    I have the basic "instruction manual" and a schematic with RF
    adjustments diagram......No service manual.

    Problem - Unable to effect a reset of any kind. Radio "stuck" in
    current configuration, and operational otherwise. Does not appear to be
    in lock mode. Function button does not cause a change into function
    mode (no menu's displayed etc).

    Operationally - Radio works fine on previously programmed channels and
    is stuck with the display in CHANNEL mode.
    - Good tx output and waveform
    - Good tx deviation
    - Good receiver operation - DTMF operates
    - Radio LCD display normal and shows channel change and s-meter bar
    graph and whatever was programmed previously.
    - Display does NOT show it's locked (no key symbol).

    Observations - Front panel pushbuttons all cause a beep to be emitted
    when pressed and a second beep to be emitted if held in for
    approx 1.5 secs. Because the programmed channels work ok (DDS ok
    assumed) and the push buttons all cause a beep to be emitted
    (generated by the microprocessor IC201) , it would seem that that IC201
    is functioning. The inability to reset or cause a change into
    "Function" mode (both with a particular change of display) leads me to
    wonder first how it won't reset. I see IC209 (PST9130NR) labelled RESET
    and input to the processor as RESET but I don't see any control to this
    other than basic ON/OFF power. IC209 appears on the schematic to be
    basically a 3 terminal regulator with the output TP tagged at 4.7
    vdc.......I measure 4.8 vdc (likely ok). Is this some sort of power up
    buffer or delay?

    Checking pins of IC201, with the radio operational, appears daunting due
    to it's location underneath the hard wired LCD.

    Has anyone had a similar troubleshooting experience with this radio OR
    knowledge of how the RESET works OR what might be locking the
    microprocessor IC201? Might the EEPROM IC210 (X25160S1-2.7) be locking
    IC201 (thinking about why the processor won't reset here.......perhaps
    the EEPROM is disabling the micropro somehow?).

    At this point, short of finding a problem with the RESET circuit (once I
    know how that works), it would appear that replacing the front panel
    module would be the only recourse.

    Any constructive suggestions welcomed.


    Gord - VE1AJF
     
  2. Clif Holland

    Clif Holland Guest

    You have tried a full reset (MR + Power on) correct???

    How about a little history on how it got this way, IE was modding the
    radio????
     
  3. I have the basic "instruction manual" and a schematic with RF
    Thats an odd one... I can only offer a bit more information to help
    diagnose this - sorry if you already know this, but from your post I'm
    not sure so here goes...

    Anything labled "RESET" on the schematic is likely related to the
    physical reset need to start the microprocessor properly. The fact
    that you have displays, beeps and some front panel activity tells
    me that the microprocessor is running. Physical RESET normally
    only happens at power on, and IC209 is likely just a reset pulse
    conditioner (holds reset low for a period of time after power has
    stabalized).

    The microprocessor normally stores it's permanent operating
    parameters in the EEPROM - when you press buttons to change
    modes, set parameters etc. It write the updated settings to the
    EEPROM and reads it when it needs to know those settings.

    What is referred to as "resetting the radio" is normally some key
    sequence at power-up which causes the microprocessor to read
    a set of factory default parameters from it's internal ROM, and write
    those parameters to the EEPROM - this effectively wipes out any
    user programming, and should cause the radio to behave exactly
    as it came from the factory.

    When you say "unable to effect a reset", I assume you mean that
    you have tried the appropriate keys at power-on, and the radio is
    not returning to defaults.

    Given that we know the processor is running, and that it can access
    the EEPROM (previously programmed channels and modes are
    evident and appear to be as programmed), then I can see only two
    likely reasons:

    1) Problem with key matrix such that the keys are not being interpreted
    correctly. If this were happening you should be able to tell (some
    keys would do the wrong function etc.)

    2) For some reason the microprocessor is unable to write the the
    EEPROM - could be that the eeprom has gone bad. Some devices
    have a write protect line, which the radio may be controlling, and it
    may be in the wrong state (bad drive etc.)

    I would check the data sheets on the EEPROM, see if there is a write
    protect line, and observe it's state during an attempt to reset the radio.
    If you have a logic analyzer or storage scope, look at the control signals
    to the eeprom and see if the microprocessor is attempting to write it
    during a reset attempt. If you can see valid write attempts, and the device
    not write protected, yet the radio remains as previously programmed, then
    replacing the eeprom might be a good next move.

    If the microprocessor does not attempt to write the the EEPROM during
    a reset attempt, then the problem lies elsewhere - perhaps in the key
    matrix which would prevent the processor from getting the command to
    reset - normally the reset jey-sequence *always* works (Can't be
    disabled).

    Dave VE3DRD
     
  4. Gord S

    Gord S Guest

    Good ideas Dave. The more I've looked at this thing, the more I keep
    looking at that EEPROM on the schematic but was getting foggy as to how
    it reacted maybe during a reset. Your description of probable
    operation of the "reset" IC209 is how I'd pictured that. Sure would be
    nice if I could just GET AT that EEPROM better! Thanks much, again,
    for tossing your thoughts back.

    73 - Gord VE1AJF
     
  5. Gord S

    Gord S Guest

    Howdy Clif. Yes I've tried the key sequence as you mentioned to no
    avail (may have mentioned it in an earlier post). The owner (a
    competent operator) indicated that the radio turned on like this at some
    point and hasn't changed. Inside the rig appears untouched and original
    with no mods or signs of rework. Rest of what I know is, as mentioned
    in a previous post. Thanks for taking the time to read.

    Gord - VE1AJF
     
  6. Gord S

    Gord S Guest

    UPDATE to my previous post:

    ---------------------------------------------------------------------------


    I've since figured out how to gain access to the processor and
    surrounding area (bend the LCD away from it's plastic cradle and then
    slide the cradle up the pins allowing the display to further uncover the
    board). Pursuant to suggestions and comments from Dave Dunfield, there
    is no scanned input key matrix on this radio....individual pushbutton
    switches pulling their respective input pins on the micropro to ground
    as required - these all work (although they don't seem to agree with the
    schematic which shows a variation of the processor from the one in this
    radio).....trying all combinations of switches + power on yielded no
    reset. Scoping the EEPROM shows that it's being accessed normally and
    that the -WP pin is always HI enabling whatever the processor wants (not
    locked). At this point it seems that the problem is, that, I can't get
    the microprocessor IC201 to either RESET or to recognize a FUNCTION
    request. It's funny that it otherwise seems to work and control the
    radio correctly.

    Does anyone have the service manual who'd look up the theory and
    sequence of reset for either of these areas? Also looking for a
    schematic which shows the microprocessor M38267M8L110FP (may be a later
    model TM261A) vs the one I have showing the M38267M8L104P.

    Any comments or further suggestions welcomed. As aside, I've also tried
    to source a replacement front panel PCB though various Kenwood sources
    who've been unable to tell me if this subunit is even available.

    73 - Gord VE1AJF
     
  7. Clif Holland

    Clif Holland Guest

    I sent a reply to a bad address, oh well....
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-