Connect with us

Icom R71 dead on MW band (am)

Discussion in 'Radio and Wireless' started by Mickeybob, Apr 28, 2018.

  1. Mickeybob

    Mickeybob

    3
    1
    Apr 28, 2018
    Hi every one, I'm new here ..I have a icom r71 SW rec that is deaf from 150khz to 3800khz ...any ideas ? the rest of seems to be ok , I changed out the battery board to the new style ...now no AM+ ....thanks m
     
  2. davenn

    davenn Moderator

    13,327
    1,769
    Sep 5, 2009

    hmmmm, that shouldn't have affected anything, I can only assume you may have shorted something out during the exercise :( ?

    EDIT ... OK, here's a link to the service manual

    https://elektrotanya.com/icom_ic-r71_service_manual.pdf/download.html

    it's going to take some work on your part to sort out if the AM stage has its power rails etc working

    have fun, ask for help where needed ....
    what test gear do you have ?

    Dave
     
    Last edited: Apr 28, 2018
  3. Mickeybob

    Mickeybob

    3
    1
    Apr 28, 2018
    It was acting flakey before the change .....would cutout like now ,but I could turn it on and off and it would pop back on.
     
    davenn likes this.
  4. davenn

    davenn Moderator

    13,327
    1,769
    Sep 5, 2009

    OK .... maybe then just a coincidence that it finally failed full time ?

    anyway please answer the other Q :)
     
  5. Mickeybob

    Mickeybob

    3
    1
    Apr 28, 2018
    Ya I think it's gone ...I have most test equip....also a skeemat for it ...might have lost the detector diode on the front end. Just wondered if anyone else ever had this problem with this unit ....
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-