Connect with us

I have a Weller W-TCP-L Soldering Station with problems

Discussion in 'Troubleshooting and Repair' started by LorenzoP, Jun 1, 2017.

  1. LorenzoP

    LorenzoP

    1
    0
    Jun 1, 2017
    The soldering iron has worked fine until yesterday, I unscrewed the base and found a disconnected white wire hanging free. In addition there is a cap missing on the two green wires but they are in tacked. I am a novice at this and attempted to test a few wires the obvious the two green and the white at no avail, I am still with no heat. I tried looking up the wire diagram but could not understand it. Does anyone know of a diagram that shows a simple armature wire diagram of the unit. Such as the black goes here the red here and so on. Please forgive me, but I am completely new at this and this soldering iron has a lot of sentimental feeling attached to it. Thank you.
     
  2. hevans1944

    hevans1944 Hop - AC8NS

    4,230
    1,995
    Jun 21, 2012
    There have been several variations on the Weller W-TCP series, but they all share the same design philosophy: a low-voltage transformer connected to a heater in series with a magnetically operated switch in the heating element. It doesn't get much simpler than that. Weller has a nice little 4-page manual you can download that shows how all this works, as well as the internal connections between the soldering iron and the transformer case. The model you have, W-TCP-L, was recently offered on eBay for $75 (used), which is a real bargain considering the price of a new one.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-