Connect with us

how to reduce noise.

Discussion in 'General Electronics Discussion' started by sid2286, Jul 6, 2012.

Scroll to continue with content
  1. sid2286

    sid2286

    102
    1
    Aug 24, 2011
    I have a design, wherein the circuit has a 24v input,

    I drive a buzzer in a astable mode for a certain condition on 5v.

    Also i drive a relay for another alarm condition. this relay is 12v(coil supply)+230vA/c 5A.

    Now the problem i'm facing is I'm driving another relay from the exixting relay and some manual switches ahead of it.

    But whenever there is a change in condition(switching action on 2nd relay). MY buzzer on the card start buzzing. :(

    I tried using an optocoupler for isolation but that too isn't helping.

    Please suggested some solution.


    Regards,
    Sid
     
  2. GreenGiant

    GreenGiant

    830
    6
    Feb 9, 2012
    If Im understanding this correctly I think that this is either connections in the switch(es) and/or the relay(s)

    do you have a circuit diagram that we can look at?
    That would help immensely
     
  3. CDRIVE

    CDRIVE Hauling 10' pipe on a Trek Shift3

    4,960
    648
    May 8, 2012
    What an odd title you chose. In our world "How to reduce noise" has totally different connotations. As previously stated..post a schematic.
     
  4. CraziestOzzy

    CraziestOzzy

    18
    0
    Jul 4, 2012
    as everyone said....photo or drawing of circuit needed.
    Usually an electrolytic capacitor on the relay prevents voltage spikes in circuit that may trigger other devices (such as normally on or off rellays) sharing the same power supply and also helps preserving relay contacts
    Its obvious you need a filter of some sort...but schema/mud-map will help
    You may have a trace or wire in the wrong place but you say you have isolated with an opto....so go with filtering as a possible fix
     
    Last edited: Jul 7, 2012
  5. sid2286

    sid2286

    102
    1
    Aug 24, 2011
    I managed to sort it out using an Emc filter at the output end of the relay.
    though I'm using an optocoupler, the ground planes are not getting isolated, so the noise factor still in picture.

    Is there a better way to isolate the output from the circuit, coz using an EMC filter everytime will be an expensive affair.

    I have attached the drawing, please have a look.

    regards,
    Sid
     

    Attached Files:

  6. Harald Kapp

    Harald Kapp Moderator Moderator

    9,663
    2,019
    Nov 17, 2011
    Your problem sounds like a matter of bad or missing supply decoupling.
    Add a 100nF ceramic capacitor between Vcc and GND as near as possible to every IC.
    Add a 10µF...100µF electrolytic capacitor between Vcc and GND near the power supply input.
     
  7. sid2286

    sid2286

    102
    1
    Aug 24, 2011
    Hi, I have connected the decoupling capacitor across the ICs, though not shown in the circuit.

    however haven't connected the cap across the power supply source.

    will give it a shot and update the results.


    thanks for the advice.

    Sid
     
  8. gorgon

    gorgon

    603
    24
    Jun 6, 2011
    Which logic family do you use for this? If it is TTL or LSTTL, the design could be iffy.

    If U4 is a LM555 you should review the design again.

    TOK ;)
     
  9. sid2286

    sid2286

    102
    1
    Aug 24, 2011
    yes its LM555 and reading about TTL and LS-ttl i guess TTL can cause glitches.

    should i replace it with LS-ttl? or is there any other alternate solution for U4 IC.

    regards,
    Sid
     
  10. sid2286

    sid2286

    102
    1
    Aug 24, 2011
    ok, I tired with the capacitor at the input of power supply.

    At the output end of the regulator of 12v and 5v I used a 100uF capacitor, and also decoupling capacitor of 0.1uF at the Vcc and Grd of all the ICs.
     
  11. gorgon

    gorgon

    603
    24
    Jun 6, 2011
    What's the value of R4 and the other pulldown resistor? For TTL pulldown is generally a bad idea, and depends on the type of gate (U1,2 &3). If it is a Schmitt trigger NAND it could be ok. A TTL input need 1.6mA current to pull it low.

    TOK ;)
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-