Connect with us

How do drive a power mosfet gate

Discussion in 'General Electronics Discussion' started by bonedoc, Jan 30, 2012.

Scroll to continue with content
  1. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    I have a situation in which I was powering a mosfet gate directly from a microchip pin. It was not working too bad until I added other components for my chip to control. So, the mosfet isnt putting out quite as much. I would like to find a simple way to use an intermediate NPN or PNP to drive my 12V rail onto the mosfet gate. I was thinking a 2n2222 or pn2907.

    The reason I ask about this is because I dont believe I am doing it right, and all the schematics on the internet are all over the place, some using NPN and PNP transistors in junction with eachother, or some elaborate setup.

    I *thought* that I would just control a 2n222 base with a microchip. I would have the collector on the 12V supply and then the emitter on the gate of the mosfet....but I am pretty sure I am wrong.

    Can someone tell me what to do?
     
  2. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    I know what those are, but was curious of another method.
     
  3. BobK

    BobK

    7,682
    1,686
    Jan 5, 2010
    I have used a single transistor and a resistor in cases where the switching is not very fast: 10KHz or less.

    For faster switching, you would need a level shifter first, then a complementary pair of transistors. And typical BJT transistors like your 2n2222 would not be fast enough. This is why they make gate driver ICs.


    Bob
     
  4. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Yeah, I just hooked a 2n222 and a 2n2907 together at the emmiters and base.....it worked, but no improvement. I am at 160k....so I guess I am out of luck!
     
  5. GonzoEngineer

    GonzoEngineer

    321
    2
    Dec 2, 2011
    TC427......it's the only thing I use! Even a 3V pic can switch it!

    Put at least 22uF on the power to the chip and you will get nice fast rise times
    with minimum losses.
     
  6. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Thanks Gonzo! I have some ordered. Out of curiosity, I will be controlling this with optocouplers. I have normal optocouplers and some logical level optocouplers. t sounds like these will work fine with logic level optos, right? 3V is low!
     
  7. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Well, I bought some. They work great. I am having some issues with the mosfet overheating now. I know it is not the duty cycle. I have tried 10-47 ohm resistors at the gate. I dont have a diode on the mosfet yet. I thin it may be latching, but I am not sure why.
     
  8. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,418
    2,788
    Jan 21, 2010
    What's your load?

    If it's inductive do you have a reverse biased diode across it?

    Is it just a single mosfet, or two, one connected to each supply rail?

    You may have posted a circuit diagram for all of this, but I can't see it.
     
  9. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Hey there, I dont have a diagram I can post right now. I am powering an inductive load. It is the primary side of an inductor. The inductor inputs 12V and outputs to the drain of the mosfet. The mosfet is a logic level nte2987. It is good to 20A/100V/105W. I am pulling about 5A. I think the peak voltage that the inductor will induce back to the mosfet is 30V. I am not running in continuous mode. I have a good heat sink. My lead to the gate is 3" long for testing. I did have a 12V zener on the mosfet, but that went up in flames ;-) I really think this is my problem. I dont know what to chose for the mosfet diode. I did not have this overheating issue when I was driving with less voltage. It was when I added the gate driver that it started to overheat. It works very good....but gets too hot. I think it may be latching.
     
    Last edited: Feb 14, 2012
  10. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,418
    2,788
    Jan 21, 2010
    You don't mention any diode across the load. I suspect you are causing a very high voltage to appear across DS and are lucky that it hasn't failed.

    The diode is essential.
     
  11. BobK

    BobK

    7,682
    1,686
    Jan 5, 2010
    This is for a boost converter right? If so, do not put a diode across the coil to suppress the voltage spike, that spike is your high voltage output!

    Bob
     
  12. (*steve*)

    (*steve*) ¡sǝpodᴉʇuɐ ǝɥʇ ɹɐǝɥd Moderator

    25,418
    2,788
    Jan 21, 2010
    hahaha, the problems of splattering things across multiple threads.
     
  13. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Yes, I am finishing up the boost converter. When I was learning about how they work, I was just pulsing my 12v rail voltage through the primary side with the logic level mosfet. It worked pretty good, I was not seeing anything over 60C. Now that I added the driver, everything is working better....but I am getting to 150C really quick, and the mosfet has a large heat sink on it. Nothing has changed but the addition of the driver.

    I tried small gate resistors in the 10 Ohm to 47 Ohm range to see if I could prevent and resonance, but that did not affect the charging or heat issue. I have read that adding a protection diode can not only protect the mosfet, but prevent latch up. I just dont know what type to use. I have heard of schottky and zener being used for this situation. I also dont know what rating of diode to get. For example, I am pulsing 12V on the primary, but the secondary side of the transformer has up to 300V. With a 1:10 winding, this means the secondary side may see 30V when the mosfet is shut off.

    I did have a 15V zener on there originally, and it caught on fire. I thought this would be good since I was pulsing 12V. I have some BAT43 schottky, and some high speed UF4007. Would one of this work? Sorry for all the basic questions. Its a learning experience for me ;-)
     
  14. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Sorry guys....didnt want to resurrect that one.
     
  15. Resqueline

    Resqueline

    2,848
    2
    Jul 31, 2009
    A diagram is always useful. You should have a circuit like the one attached.
    Information like inductance and on/off times are also crucial for the problem.
    What is the peak inductor current, and what does the current ramp look like?
     

    Attached Files:

  16. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    Ipk is 5A and the inductance is 10uH. The leakage inductance is .144uH. There is a 1:10 turn ratio. The max on time by the calculations was 4.0us, so I did a period of 2 times this = 125kHz. I then did a 40% duty to be safe. I see that diagram you posted. It looks similar to mine, minus the caps, resistors, and diodes ;-)

    It looks like there are some small resistors in there to dampen things? How one gets these small resistor values....I dont know. Maybe it is just a standard?

    I too used a 15V diode like the diagram, but mined burned. That is why I am confused.

    PS- Thanks for posting that schematic!
     
    Last edited: Feb 14, 2012
  17. twister

    twister

    172
    7
    Feb 12, 2012
    If you only have 12V on the coil you need a lower voltage mosfet. Your mosfet has .09 ohms on resistance. A lower voltage mosfet only has .01 ohms and therefore less heat.
    It sounds like you are not turning the transistor completely on and therefore the transistor has to dissipate more heat. You need at least 5V to turn that transistor on. Also you need a gate resistor to protect your driver in case the transistor shorts. I suggest a 10K ohm. I would put a 3 amp shotkey diode in reversed bias to protect the mosfet.You really shouldn't need a driver if you have over 5v from your oscilator. Does your oscilator put out square waves? If sine waves you will have to dissipate much more heat, and maybe need to use two or more transistors. Here is the data for that mosfet..
    http://www.datasheetcatalog.com/datasheets_pdf/N/T/E/2/NTE2987.shtml
     
  18. bonedoc

    bonedoc

    122
    0
    Dec 21, 2011
    The application note that I was following recommended a NPN that has a DS rating of at least 80V, so I cant really go much smaller. I thought that the entire premise of a logic mosfet was to allow for smaller voltages? My pic pin wasnt driving the gate hard enough, and that is why I added the driver. It is pulsing 12V to the gate.I also thought that one should try to not have any gate resistor, and that you shouldnt go higher than 47 ohms or so, and that the only purpose in this case is to eliminate resonance? Sorry for the questions, I was headed in one direction, and I think I am hearing the opposite. Everything worked fine without the driver, less heat...but slower charges. With the driver, it it working wonders....but HOT.
     
  19. twister

    twister

    172
    7
    Feb 12, 2012
    Maybe you don't need a gate resistor, but if your transistor shorts it will take out the driver too. With a 47 ohm resistor it would allow 250 ma of current. Will your driver take that much? Not sure why you can't go with a higher ohm gate resistor. A mosfet doesn't take much power to drive it. I don't understand why the pic wouldn't drive it. How much voltage does it put out? It shouldn't make any difference in the heat whether you drive it from the pic or a driver.
    I would like to see your schematic. Do you have a resistor from gate to ground? A mosfet has to be biased off.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-