Connect with us

Help with Tektronix TDS-3012B Oscope

Discussion in 'General Electronics Discussion' started by HellasTechn, Jun 12, 2019.

  1. HellasTechn

    HellasTechn

    1,403
    195
    Apr 14, 2013
    Hello !

    I Use a Tektronix TDS-3012B Oscope and i get this little strange behavior on both channel A and B. Even with no probe connected or with the probe connected and shorted to GND, i do get readings on the display that range from 0 to 100mv peak to peak. and from 0 to 400K frequency.
    like shown in the pictures below. The same happens when i measure DC voltage. Also the resolution does appears to be far from perfect. I know that it takes samples of the signal but should it not look more like a solid line? also i do not know how to set it to use maximum sampling rate. Not to mention that i have an Oscope back from 1979 that its trace is sharp as a blade. I do not expect the display of an old digital scope like this to be as good as the display of an analogue one but... the readings ? This is a problem for me specially when i try to measure the ripple voltage of my buck converter.
    I have done the signal path calibration but no change.

    What am i doing wrong ?

    THANK YOU!
     

    Attached Files:

    Last edited: Jun 12, 2019
  2. Externet

    Externet

    697
    142
    Aug 24, 2009
    I would first perform the same test in another room, house, environment, mains power, to compare, with as many things as possible around it off.
     
  3. HellasTechn

    HellasTechn

    1,403
    195
    Apr 14, 2013
    I know... I have but no change. I have also tried two other scopes of the same model and all give me the same thing...
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-