Connect with us

Help with open collector output

Discussion in 'General Electronics Discussion' started by starscream, Sep 27, 2015.

Scroll to continue with content
  1. Alec_t

    Alec_t

    2,940
    799
    Jul 7, 2015
    Good to know it's working now.
     
  2. Old Steve

    Old Steve

    734
    169
    Jul 23, 2015
    Glad to hear that it's working well. And that explains the puzzling voltage from the open-drain output.
    Have you considered powering the receiver from the (larger, I assume) 12V battery, or is the motor and 12V battery a distance away? Then you wouldn't need to worry about regularly replacing 9V batteries. They don't have a very large capacity.
     
  3. starscream

    starscream

    17
    1
    Sep 27, 2015
    A 12v supply would certainly simplify the whole design but i wanted to keep the enclosure containing the receiver as small as possible hence the 9v battery.
     
  4. Old Steve

    Old Steve

    734
    169
    Jul 23, 2015
    That's understandable. Is it possible to run the 12V wires back from the battery with the motor / relay wires? Just a thought.
     
  5. GPG

    GPG

    452
    66
    Sep 18, 2015
    I'd still dispense with the relay and drive the motor from the receiver.Just measure the voltage on the output driving a known current and you have the on resistance . Unless you are driving a large load it will be negligible. I'd expect it to be ~ .025Ω
    So would I as above
     
    Last edited: Oct 2, 2015
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-