Connect with us

Help with Ferguson W7022U TV

Discussion in 'Electronic Repair' started by Dave Bullock, Mar 19, 2007.

Scroll to continue with content
  1. Dave Bullock

    Dave Bullock Guest

    Help,
    My Ferguson W7022U TV won't come on.
    The red standby light is working and the set monentarily comes to life when
    I use the remote.
    However during the usual delay that the set takes to check all is well
    before the CRT fires up, the set switches back to standby and it makes the
    usual 'plop' in the speakers as it did when normally switching off.
    Over the two days before completely failing it took to switching itself off
    and on at random.
    Can anyone point me to the 'STOCK' faults.
    Thanks....
    Dave
     
  2. b

    b Guest

    Dave Bullock ha escrito:
    which chassis is this? if you intend to solve this yourself or ask
    for assistance, you'll need that info. Likely a Thomson. Look for
    something starting with an ICC or TX on stickers on the rear of the
    chassis.
    You will also have to take some measurements and do some basic fault
    diagnosis- start with the most likely - remove the horizontal
    transistor and connect a 60-100 w bulb across c-e, see if there is b
    +: if so, measure it.
    chances are the set is protecting itself due to a short, often in the
    horizontal /line stage or on the vertical/frame output chip - 2
    common culprits.
    Anyway lets not get ahead of ourselves - post results of the tests and
    we'll take it form there!

    Note that there are safety hazards involved , if none of the above
    makes sense to you then don't play about, take it to a tech. You could
    screw it up beyond economical repair or kill yourrself if you go
    poking around!
    -B.
     
  3. Dave Bullock

    Dave Bullock Guest

    OK Thanks,

    It's an ICC17 and the red LED on the front is flashing 2 and 7 so 27 which
    is a deflection fault of some sort.
    Obviously the STANDBY supply is OK but the set has been coming on
    momentarily and then going off and no amount of remote button pressing will
    get it to come on again.
    So I suspected deflection faults and started faultfinding with my set
    powered through an isolation transformer.
    I shorted pin 4 of IP95 to GND and the voltages for U-TIMER, U-SYS, 5VUP,
    +UA and U-VIDEO are correct but only for a few seconds then they all go
    dead, I am now suspecting a SwitchMode fault?
    Any ideas gratefully recieved.

    Thanks...Dave
     
  4. b

    b Guest

    looks like the line stage. Did you remove the line transistor and
    check b+? that should be one of the first tests when these problems
    are suspected. From there check the vertical /frame IC - and before
    changing it see if its feed resistor is open.

    here's a few related stock faults as requested.
    good luck.
    B.

    ICC17 "ERR27",LOPTX MOD KIT(35175720)
    ICC17 "ERR27",ZL11 ZL13,FIELD O/P
    ICC17 3 TRIPS/DEAD LED(FAULT27)(LOPTX1273 SEME KIT).
    ICC17 CRT BASE SPARKS,LOPTX(HR8317) ADD 470PF2KV ACROSS LOPTR
    ICC17 DEAD DP21, 39V ZENER
    ICC17 DEAD "25" FLASHES,LOPTX(KIT)
    ICC17 DEAD BENT SIDES,TL41(BC241C/TIP41C)
    ICC17 DEAD CHOPTR(BU2525AX),TP42(B857B SM),TP57,TP58,TP59
    ICC17 DEAD CHOPTR,TP44(2SA1020Y),DP42(LL4148)
    ICC17 DEAD CUST CNTRL PANEL NO 5V TO IR RECIEVER.
    ICC17 DEAD DP21(39V ZD) LOC121
    ICC17 DEAD DP21,39V ZENER
    ICC17 DEAD ERR 27,FIELD TDA8351,ZL13
    ICC17 DEAD FLASH 2/7,RP63(432K) HT VOLTAGE SENSING
    ICC17 DEAD FLASHING LED SHORT COLLECTOR OF TL71 TO EMITTER,FIELD ZL11
    CP
    ICC17 DEAD FUSE BUH1215 (TP50). PSU REPAIR KIT (CHARLES HYDE -
    20104QK)
    ICC17 DEAD LED FLASHS 2,7 CL25(1UF25V),CL24(360NF),TL41(BC241C/TIP41C)
    ICC17 DEAD LED FLASHS 2,7 RP63(432K)
    ICC17 DEAD LOPTX ARCING DON'T USE HR TYPE
    ICC17 DEAD LOPTX+LOPTR
    ICC17 DEAD RED LED,2 PULSES 7 PULSES LOPTR,IF01 ZL11 FIELD CHIP
    ICC17 DEAD ZL13,TDA8351
    ICC17 DEAD,DP06(BZW04-342) ACROSS BRIDGE RECT
    ICC17 DEAD/STBY LOPTR(BUH516)
    ICC17 DISABLE TRIP SHORT ACROSS C/E OF TL17
    ICC17 DISABLE TRIP SHORT COLLECTOR TL71(SM) TO EARTH, LOC41
    ICC17 DISABLE TRP BY TL71(C TO CHASSIS) NR CREEN CAN UNDER PCB
     
  5. mariomatis

    mariomatis

    1
    0
    Oct 16, 2010
    [QUOTE = Dave Bullock; 596.632] Aiuto,
    Il mio Ferguson TV W7022U non si accendono.
    La luce rossa di standby è di lavoro e il set si monentarily alla vita, quando
    Io uso il telecomando.
    Tuttavia, durante il consueto ritardo che l'insieme prende per controllare tutto è andato bene
    prima che il CRT fuochi in su, il set torna alla modalità standby e rende il
    usual 'plop' dei diffusori come quando normalmente spegnimento.
    Nel corso dei due giorni prima di non aver completamente che ci voleva per sé spegnimento
    e su a caso.
    Qualcuno mi può punto a difetti del 'magazzino'.
    Grazie ....
    Dave [/ QUOTE]
    Sono mario dall'Italia
    Buongiorno volevo chiedere a Dave Bullock se è riuscito a risolvere il suo problema
    sul telaio icc17 tv thomson perche anche io ho lo stesso problema che mi fa impazzire!
    ho gia controllato decine di volte i componenti e cambiato il tr di riga(hr8317)
    ma cotinua a darmi error 27
    grazie mario
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-