Connect with us

Help with a synth repair/power supply fault

Discussion in 'Troubleshooting and Repair' started by Crick, Jun 26, 2012.

Scroll to continue with content
  1. Crick

    Crick

    17
    0
    Jun 12, 2012
    Hi guys,

    I've been given an old Casio CZ1000 to repair. Its a synth from 1984 and minor power supply faults are quite common with this synth apparently. Problem with this one is that its not turning on.
    I've done the obvious, checked the supply is working, opened it up and had a look at the connections. Someone has done a terrible solder job on the barrel socket connector and the actual pads on the board were none existant so i soldered on a piece of jumper wire to the next possible solder point and i seem to be getting a nice voltage from there on but the problem still remains, it wont power up.

    The service manual can be found at this link: http://www.studio250.fr/docs/casio/casio cz101servicemanual.pdf

    Page 3 shows the supply circuit. The bottom right of the circuit shows the power switch. It can either run off batteries or a plug. There is a switch right at the power supply socket then there's another push button switch on a smaller sub circuit which is the one on the bottom right of the circuit. I'll have to come back to this post tomorrow and post the voltage readings i got at each point (i've it powered off and all my stuff put away now, stupid, i know!) but if you look at that circuit you'll see an LED in series with a 390(?)Ohm resister. This LED isn't lighting up. The voltage at the resistor is around 300mV i think but on the other side of the LED the voltage drops way down. Could it be faulty at all? Could it be the cause of the problem?

    To be honest, my fault finding skills are quite poor as i've never really put them to use in the workplace, i'm more of an electronics assembly type guy but i'm trying to learn! If anyone could give me any advice on how to go about fault finding this that would be great!

    Some info on the synth can be found here: http://www.madtheory.com/CZ article/CZ article.htm

    Cheers in advance!
     
  2. KJ6EAD

    KJ6EAD

    1,114
    157
    Aug 13, 2011
    That manual is pretty low resolution so I'll just offer a few general hints. First, be sure your supply works, then the connector, then any fuses. If your supply voltage is present past that point, I'll be slightly surprised. If not, you should measure the current being sucked out of the supply.

    Often the supply voltage will be routed to separate sections of the PCB or PCBs through connectors that make a low resistance fault easier to isolate by disconnecting or reconnecting those branches one by one. It's also typical for the main DC supply to be regulated down to supply one or more lower voltages and checking the output(s) of those regulators for the presence of correct voltage would be an early troubleshooting step.
     
    Last edited: Jun 27, 2012
  3. Crick

    Crick

    17
    0
    Jun 12, 2012
    Cheers. I'll have to work through that later.

    I might also add that the fault began after the synth had been dropped so chances are something's physically broken.
     
  4. KJ6EAD

    KJ6EAD

    1,114
    157
    Aug 13, 2011
    In that case, close visual inspection giving particular scrutiny to any high mass components such as transformers and large capacitors is in order as well as areas of the board(s) near mounting bosses, fasteners and case penetrations.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-