Connect with us

Help, my USB devices keep getting spiked/destroyed!

Discussion in 'Hobby Electronics' started by Shannell Sugrue, Jul 30, 2004.

Scroll to continue with content
  1. I have a NF7 abit motherboard and a codegen 400w powersupply Ive broken 2
    USB devices so far, a canon i560 printer and a logitech wireless joystick.
    The printer worked fine on other machines, then I plugged it into mine and
    it wasnt recognised by the usb device detect thing, put it back on the other
    machines and same problem, still worked on the parrallel port though but I
    took it back and got another and the exact same thing happened, canon
    verified that a chip had blown. Ive kept this one as it must be at my end.
    Next up is the usb reciever/dongle from my new wireless joystick, joystick
    worked fine then I swapped from the usb connection off a header to the MB to
    the usb connection at the back of the case, next thing you know "device not
    recognised" and cant be recognised in any other machine either, and the
    light on the front of the reciever/dongle doesnt work any more although Im
    not sure if it was on all the time it was plugged in or just when it detects
    a signal. So whats going on here? I have several other devices that work
    fine on any of my usb ports, card readers, wireless access point, ISDN
    modem, PDA, drawing tablet etc. Perhaps these 2 devices were more sensitive
    to voltage and got "burnt"? Im reasonably savvy electronically so I can run
    some tests if anyone has anything they could think of to check? Any help
    appreciated.
     
  2. mikegw

    mikegw Guest

    I had this happen on one of my usb connectors. The pinout of the usb header
    on the mobo is not standard across all manufacturers. Smart money is
    the -ve and +ve pins on the usb port are swapped. The data ones could be
    too but that wont nuke anything. Maybe something's have reverse bias
    protection??

    HTH

    Mike
     
  3. eltan

    eltan Guest

    read the manual for the motherboard & usb devices.

    I know some devices required software driver to be installed first &
    restart, and the devices connect to it after the os is loaded.

    The usb devices is probably "fried" during power up.
     
  4. The joystick wasnt, it was "fried" while the pc was already powered up.
    Surely these devices cant be zapped by a normal startup just because of
    drivers? the drivers dont even kick in until winxp is loaded, and the
    voltage should be constant anyway? Ive got some voltage monitoring software
    installed and its at a steady +5.03v ( I presume its the + and not the -)
     
  5. If the connectors are hardwired to the motherboard then possibly the
    motherboard or connectors are faulty.

    If the connectors are in a slot with wires running back to the board,
    they could be connected wrongly.

    Your MB documentation will show which pins on the motherboard connectors
    are which.

    Taken from http://www.dse.co.nz/isroot/dse/support/XH3243-PINOUT.TXT
    The pinouts of the USB sockets are

    Socket End

    pin
    4 3 2 1
    -----------
    | n n n n |
    | -------- |
    -----------

    Pin Name Description
    1 VCC +5VDC
    2 D- Data -
    3 D+ Data +
    4 GND Ground

    Measure these with a multimeter to see if the 5V and ground are in the
    right place.
     
  6. I went out and bought an Antec power supply today, got a replacement
    joystick and so far everything is ok...
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-