Connect with us

Help mitre saw blows house fuse

Discussion in 'Troubleshooting and Repair' started by Mike Hanson, Aug 23, 2015.

Scroll to continue with content
  1. Mike Hanson

    Mike Hanson

    3
    0
    Aug 23, 2015
    Hi everyone.

    I bought a proxxon kgs 80 mitre saw.

    it worked about 20 times and then failed resulting in every time the power button is pressed it blowed the fuse in the mains power box when I say blows the fuse I mean switches off all the the plug sockets.

    I sent it back to the seller who says they repaired it but the exact same thing happened it worked fine for about 20 times and then blows the fuse it as even blown the microswitch that the on/off button pushes.

    I asked for a refund but they wont even answer my emails now. I have resulted in taking the saw apart looking for any obvious problems. I cant see anyting wrong I changed the microswitch but the new one just blew again.

    Any ideas what i can try or what it could be?

    Also the saw came with a euro 2 pin plug but no uk adapter. I was told I could cut off the plug and fit a uk plug. I connected the earth live and neutral to the uk plug any ideas if this could this be the cause?

    inside.jpg proxxon.JPG
     
  2. Martaine2005

    Martaine2005

    3,515
    953
    May 12, 2015
    Hi Mike,
    Are you sure this is a 240v unit?
    I t should have the input voltages on a small plate or sticker.

    EDIT: How did you fit an earth to it from a 2 pin Euro plug? It would have only had 2 wires.

    Martin
     
  3. Minder

    Minder

    3,093
    664
    Apr 24, 2015
    I would assume it should be earthed due to having the wired ground conductor.
    As mentioned, ensure it is 240v motor, but I believe they are UK origin so it possibly is correct.
    Usually these are fitted with a Universal motor and there is quite a high inrush although it appears quite a small motor is fitted.
    If it get to be a nuisance blowing of the fuse, you could feed it off of the dimmer style variable controls and bring the rpm up slowly.
    Have you fused it correctly?
    M.
     
  4. Arouse1973

    Arouse1973 Adam

    5,165
    1,087
    Dec 18, 2013
    Put it back together and tell them your going to contact trading standards or HSE. it shouldnt do this if rated for the UK and your using it from a standard UK wired socket.
    Adam
     
  5. Mike Hanson

    Mike Hanson

    3
    0
    Aug 23, 2015
    Thanks for the reply's it is very much appreciated.

    To answer your questions.
    I put a plug on with a 13amp fuse. The 2 pin plug that I cut off had a 16amp rating (see photo)
    Although the original plug was 2 pin when I cut it off it did reveal 3 wires in the standard uk colours.
    The saw as a voltage of 220- 240v (see photo)
    Just noticed something is scratched above the sticker looks like 76g 75v any ideas what that could mean
    Cheers for your help
    Mike label.jpg plug.jpg
     
  6. Bluejets

    Bluejets

    4,870
    1,017
    Oct 5, 2014
    16A is the rating of the plug, not the machine.
    At 200W it should only draw a couple of amps at startup........
    As Adam says, contact the trading standards.
    I think you will find the seller should have the correct plug already fitted.
     
  7. duke37

    duke37

    5,364
    772
    Jan 9, 2011
    The original plug is three pin. One of the pins is on the socket. It will be connected with three wires.
     
    Last edited: Aug 24, 2015
  8. Tha fios agaibh

    Tha fios agaibh

    2,166
    726
    Aug 11, 2014
    Good advice from Adam.

    As far as what's wrong, ....perhaps a bad ptc?
     
    Martaine2005 likes this.
  9. Mike Hanson

    Mike Hanson

    3
    0
    Aug 23, 2015
    Thanks Guys for all the help and information.

    I will take Adams advice... put it back together and contact trading standards.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-