Connect with us

Help in repair of TS-1564 Soldering Station

Discussion in 'Troubleshooting and Repair' started by argypak, Nov 10, 2012.

Scroll to continue with content
  1. argypak

    argypak

    2
    0
    Nov 10, 2012
    Hi Guys,

    I'm new here and quite an illeterate when it comes to electronics.
    The extent of my knowledge is that I can solder a component or wire.

    Having said the above, I'm wondering it someone can help.

    I purchased a soldering station for soldering connectors to lipo batteries for rc helis. Recently I needed to change the tip, which I did, but after which the station shorted out. The soldering station is a Duratech TS-1564 available from Jaycar in australia.
    http://www.jaycar.com.au/productView...SUBCATID=953#1

    Rather than purchase a new soldering station, I thought it might be worth trying to fix the faulty one.

    One opening the unit I found a number of resistors that were faulty.
    I took the board back to Jaycar, where they were able to provide me with replacement resistors. After soldering the resistors on the board, I turned the unit on with a replacement pen and one of the large resistors started to smoke again.

    I am assuming that something else is damaged, but I'm not sure on how to proceed.

    Any help would be appreciated
     

    Attached Files:

Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-