Connect with us

Help diagnose LTQ70 soldering iron no heat

Discussion in 'Troubleshooting and Repair' started by mikey5791, Oct 30, 2020.

Scroll to continue with content
  1. mikey5791

    mikey5791

    163
    16
    Jun 7, 2013
    Hi forum friends,
    Once again i come to this forum for assistance. In the past, i have been getting a generous amount of help in repairing and appreciate it so much.
    This morning i found out this soldering iron no more producing any heat, but the neon light is on. I pressed the button to heat up to the hotter 70w setting and it still no heat. It has a normal setting of 30w, but another higher setting at 70w if i press that orange color switch.
    I opened up the casing but found nothing burned or melted. Can anyone point me to where should i start looking and testing where is the fault.
    Thank you.
     

    Attached Files:

  2. Harald Kapp

    Harald Kapp Moderator Moderator

    11,444
    2,628
    Nov 17, 2011
    Check the resistance of the heating element with an Ohmmeter. The heating element's wire can break after long use. I had to replace my old soldering iron recently for exactly this reason.
    It is unlikely that you will find an affordable replacement heating element. I guess you're in for a new soldering iron.
     
  3. Martaine2005

    Martaine2005

    3,415
    928
    May 12, 2015
    The neon will light, it’s connected across the mains input.

    Martin
     
  4. mikey5791

    mikey5791

    163
    16
    Jun 7, 2013
    Hi,
    Thanks for reply.
    I am ordering a new set of temperature adjustable soldering iron soon.
    Hope it will be useful for many tasks ahead.
     
    Martaine2005 likes this.
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-