Connect with us

'HELP' 46" RCA Projection TV

Discussion in 'Electronic Repair' started by Sparky, Oct 12, 2003.

Scroll to continue with content
  1. Sparky

    Sparky Guest

    I have a RCA 46" projection TV with a Hitachi chasis. The problem I am
    having is that the TV keeps blowing a fuse. When it blows the fuse the
    screen flashes red and goes blank and the sound stays on. I no longer
    have a picture. Is there anyone out there who can help me diagnose
    this problem. I have the schematics.
    Thanks
     
  2. David

    David Guest

    Which Hitachi Chassis?
    What troubleshooting have you done so far?
    What were the results of the Google Groups search for similar model
    problems?
    David
     
  3. Sparky

    Sparky Guest

    David,
    I tried looking for the chassis information and couldn't find it.It is
    a Colortrak 2000. The model number is P46000T made in 1989. When the
    electrician came in to fix it he did some basic trouble shooting and
    said it had to be taken in for a more intense look. When he got the TV
    in his shop he found that it had blown a fuse. So he replaced the fuse
    and brought it back to me. He said it may or may not blow again and if
    it does to just replace the fuse. He said that it would be hard to
    find out what the problem was until something started to smoke or
    something went out. He mentioned that the underline problem could be a
    drive as this makes the transistor blow a fuse. I did notice that he
    replaced the fuse with a 2amp 250v and the TV calls for a 1.5amp 125V
    could this be a problem? I have replace 2 fuses 2amp 250v quick acting
    fuse twice in about 15 hours of veiwing.
    Thanks for your interest,
    Val
     
  4. Sparky

    Sparky Guest

    David,
    I tried looking for the chassis information and couldn't find it. The
    model number is P46000T made in 1989. When the electrician came in to
    fix it he did some basic trouble shooting and said it had to be taken
    in for a more intense look. When he got the TV in his shop he found
    that it had blown a fuse. So he replaced the fuse and brought it back
    to me. He said it may or may not blow again and if it does to just
    replace the fuse. He said that it would be hard to find out what the
    problem was until something started to smoke or something went out. He
    mentioned that the underline problem could be a drive as this makes
    the transistor blow a fuse. I did notice that he replaced the fuse
    with a 2amp 250v and the TV calls for a 1.5amp 125V could this be a
    problem? I have replace 2 fuses 2amp 250v quick acting fuse twice in
    about 15 hours of veiwing.
    Thanks for your interest,
    Val
     
  5. David

    David Guest

    In any case, the set with the monolithic ceramic horizontal drive module are
    knwon for those going bad. Bath chassis designs are known for the hv
    splitter failing. Plus do not forget about high esr electrolytic capacitors
    due to the extreme old age of the unit.
    David
     
  6. James Sweet

    James Sweet Guest

    If the screen flashes red maybe the red tube has an intermittant short?
     
  7. Sparky

    Sparky Guest

    David,
    Do you have any suggestion on how to fix this or can you tell me how
    to narrow the problem down?
    Thanks
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-