Connect with us

Guitar Preamp

Discussion in 'Troubleshooting and Repair' started by PhilNorris, Apr 30, 2015.

Scroll to continue with content
  1. PhilNorris

    PhilNorris

    1
    0
    Apr 30, 2015
    Hi People,

    I have a preamp - its a Mesa Boogie Triaxis. It's started to rumble on the output. That's the best way to describe it, like distant thunder, some standard component that is shot, loading up with a charge or releasing it sporadically. It still works, sound comes thru it, but I can't really use it with the rumble for anything serious. The guy who used to fix it has moved away, he once said that it was typical for those XXXXX's to go like that.

    Here's a link to the schematic

    http://www.schematicsunlimited.com/...triaxis-amplifier-schematic/download/ODk4Nw==

    Does any body have an idea what kind of component might be a candidate? I suppose I can test some components, I have a scope (although I'm not sure how to use it yet). It would sure be cheaper to find out what is causing it and fix it myself.

    Thanks.

    Phil.
     
  2. Arouse1973

    Arouse1973 Adam

    5,164
    1,078
    Dec 18, 2013
    My first thought would be the power amp tubes or a faulty power supply capacitors. Also have a look over the PCB and see if you can see any dry joints.
    Thanks
    Adam
     
  3. Skezza

    Skezza

    15
    0
    May 3, 2014
    Sounds like the pre-amp tubes to me. Do you have a tube tester?
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-