Connect with us

Grundig CTV with white screen then powers off

Discussion in 'Electronic Repair' started by radio10, Jun 16, 2007.

Scroll to continue with content
  1. radio10

    radio10 Guest

    Have a Grundig T70-1020 ctv that powers up with a full white/pinkish
    screen with flyback lines showing but no picture discernable (sound is
    ok), then after 10 seconds psu shuts down back to standby. Something
    EHT perhaps? All comments welcome.

    Richard
    UK
     
  2. JANA

    JANA Guest

    This is usually caused by a short in the CRT. It is possible, but rare, to
    have a failure in the driver circuits to the CRT. With proper
    troubleshooting, the actual fault can be determined.

    --

    JANA
    _____


    Have a Grundig T70-1020 ctv that powers up with a full white/pinkish
    screen with flyback lines showing but no picture discernable (sound is
    ok), then after 10 seconds psu shuts down back to standby. Something
    EHT perhaps? All comments welcome.

    Richard
    UK
     
  3. Guest

    If there were an EHT problem the screen would be black.

    Check voltages on the various crt electrodes - except for anode &
    focus of course.


    NT
     
  4. radio10

    radio10 Guest

    Thanks to all for your helpful comments.
     
  5. John

    John Guest

    Could be missing the supply to the video output stages this would cause
    maximum beam current followed by the set tripping out.
    John.
     
Ask a Question
Want to reply to this thread or ask your own question?
You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Electronics Point Logo
Continue to site
Quote of the day

-